summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/frei0r-plugins/Manifest3
-rw-r--r--media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch42
-rw-r--r--media-plugins/frei0r-plugins/frei0r-plugins-1.3.ebuild37
3 files changed, 0 insertions, 82 deletions
diff --git a/media-plugins/frei0r-plugins/Manifest b/media-plugins/frei0r-plugins/Manifest
deleted file mode 100644
index 97aa8b0..0000000
--- a/media-plugins/frei0r-plugins/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX frei0r-plugins-1.3-no-automagic-deps.patch 1867 RMD160 3dcf3fb447ff842475d2a200515c3f89d8909396 SHA1 1dc648e98f6f1d461319d702748979753ea84984 SHA256 5b14f0d887116af3e935d53ca10631892a2e93d70ac443865ed2fdfc38eb4b47
-DIST frei0r-plugins-1.3.tar.gz 1092809 RMD160 abc279996bb5ffe83f796e1699c9b1cdbece60ec SHA1 f6b463440017934d01ac3c8fdf70b93c915e3d08 SHA256 b25da901115aa7f960cf5e541057266fddf132a7521d628e6cb344c9f16c0236
-EBUILD frei0r-plugins-1.3.ebuild 827 RMD160 5eb79aa8b54f5ff4402658352d00a00b5ddde69e SHA1 c5a4167743dfc4192d67c6a118cfbc6051f505fb SHA256 07f1d28b50c8293357acb8bb161623f91f052c627652da43c200a2b38baae0d2
diff --git a/media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch b/media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch
deleted file mode 100644
index 616dcc8..0000000
--- a/media-plugins/frei0r-plugins/files/frei0r-plugins-1.3-no-automagic-deps.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- configure.ac.orig 2011-05-04 00:17:15.370171000 +0200
-+++ configure.ac 2011-05-04 00:26:27.583170991 +0200
-@@ -93,18 +93,35 @@ AC_C_INLINE
- AC_FUNC_MALLOC
- AC_CHECK_FUNCS([floor memset pow sqrt])
-
-+
-+AC_ARG_ENABLE([facedetect], [ --enable-facedetect enable facedetect plugin (needs opencv)],
-+ [facedetect=${enableval}], [facedetect=no])
-+
- HAVE_OPENCV=false
--PKG_CHECK_MODULES(OPENCV, opencv >= 1.0.0, [HAVE_OPENCV=true], [true])
--AM_CONDITIONAL([HAVE_OPENCV], [test x$HAVE_OPENCV = xtrue])
--if test x$HAVE_OPENCV = xtrue; then
-+if test "x${facedetect}" = xyes; then
-+ PKG_CHECK_MODULES(OPENCV, opencv >= 1.0.0, [HAVE_OPENCV=true], [true])
-+ if test x$HAVE_OPENCV = xtrue; then
- # OPENCV_CFLAGS="$OPENCV_CFLAGS -DOPENCV_PREFIX=`pkg-config opencv --variable=prefix`"
- AC_DEFINE(HAVE_OPENCV,1,[compiled including opencv])
- AC_DEFINE(OPENCV_DATA_DIR,[${prefix}/share/opencv],opencv data prefix)
-+ else
-+ AC_MSG_WARN([*** opencv >= 1.0.0 not found - this program enables optional plugin with the Open Source Computer Vision library >= 1.0.0 http://opencvlibrary.sourceforge.net/ ***])
-+ fi
- fi
-+AM_CONDITIONAL([HAVE_OPENCV], [test x$HAVE_OPENCV = xtrue])
- AC_SUBST(HAVE_OPENCV)
-
-+
-+AC_ARG_ENABLE([scale0tilt], [ --enable-scale0tilt enable scale0tilt plugin (needs gavl)],
-+ [scale0tilt=${enableval}], [scale0tilt=no])
-+
- HAVE_GAVL=false
--PKG_CHECK_MODULES(GAVL, gavl >= 0.2.3, [HAVE_GAVL=true], [true])
-+if test "x${scale0tilt}" = xyes; then
-+ PKG_CHECK_MODULES(GAVL, gavl >= 0.2.3, [HAVE_GAVL=true], [true])
-+ if test x$HAVE_GAVL = xfalse; then
-+ AC_MSG_WARN([*** gavl >= 0.2.3 not found - this program enables optional plugin with the gmerlin audio video library >= 0.2.3 http://gmerlin.sourceforge.net/ ***])
-+ fi
-+fi
- AM_CONDITIONAL([HAVE_GAVL], [test x$HAVE_GAVL = xtrue])
-
- AC_CHECK_PROG([DOXYGEN], [doxygen], [doxygen])
diff --git a/media-plugins/frei0r-plugins/frei0r-plugins-1.3.ebuild b/media-plugins/frei0r-plugins/frei0r-plugins-1.3.ebuild
deleted file mode 100644
index ad9ed35..0000000
--- a/media-plugins/frei0r-plugins/frei0r-plugins-1.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-inherit base eutils autotools multilib
-
-DESCRIPTION="A minimalistic plugin API for video effects"
-HOMEPAGE="http://www.piksel.org/frei0r/"
-SRC_URI="http://www.piksel.no/frei0r/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc facedetect scale0tilt"
-
-DEPEND="facedetect? ( media-libs/opencv )
- scale0tilt? ( media-libs/gavl )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/frei0r-${PV}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-no-automagic-deps.patch
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable facedetect) \
- $(use_enable scale0tilt) \
- --libdir=/usr/$(get_libdir)
-}
-
-src_install() {
- base_src_install
- use doc && dohtml -r doc/html
-}