summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/eo/eo-1.2.0.ebuild')
-rw-r--r--sci-libs/eo/eo-1.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/eo/eo-1.2.0.ebuild b/sci-libs/eo/eo-1.2.0.ebuild
new file mode 100644
index 0000000..4c74d09
--- /dev/null
+++ b/sci-libs/eo/eo-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils
+
+MY_P="EO-${PV}"
+
+DESCRIPTION="Evolving Objects library: an Evolutionary Computation Framework"
+HOMEPAGE="http://eodev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/eodev/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc "${S}"/{AUTHORS,CHANGELOG,NEWS,README,THANKS,ToDo}
+
+ if use doc ; then
+ dohtml "${S}"/tutorial/*
+ fi
+}