summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/eo')
-rw-r--r--sci-libs/eo/Manifest3
-rw-r--r--sci-libs/eo/eo-1.2.0.ebuild34
-rw-r--r--sci-libs/eo/metadata.xml15
3 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/eo/Manifest b/sci-libs/eo/Manifest
new file mode 100644
index 0000000..ac3fb07
--- /dev/null
+++ b/sci-libs/eo/Manifest
@@ -0,0 +1,3 @@
+DIST EO-1.2.0.zip 4598794 RMD160 e4b4d66e479c66d64fb5626bf571f6f40390f7bd SHA1 f74d9c43d9f7cd097a1dbd0e2221e5d86f7a2038 SHA256 9f06e29bba15bae395db8dd2a261b33a10856ecec46a34562796e30488e9688b
+EBUILD eo-1.2.0.ebuild 621 RMD160 b3b091f7c4870fdcd3f2fbcca628f75db7c3e353 SHA1 e01a2783a71d34b6b48ba8190b8778d49ffa74aa SHA256 89f4e2d955c579c458ffaec2f4b58adf7f0c7b8df0ddab893dbd22bb36d2b06b
+MISC metadata.xml 529 RMD160 f3015d0c0b5c497ec49fa75c35a3859250abce24 SHA1 c03c3d3bc7511305753c89e9355a757c576809de SHA256 224d0f788b6ead33ac6c8182d9503ccb7217fd97a9985878ce645d76a5d8a585
diff --git a/sci-libs/eo/eo-1.2.0.ebuild b/sci-libs/eo/eo-1.2.0.ebuild
new file mode 100644
index 0000000..4c74d09
--- /dev/null
+++ b/sci-libs/eo/eo-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils
+
+MY_P="EO-${PV}"
+
+DESCRIPTION="Evolving Objects library: an Evolutionary Computation Framework"
+HOMEPAGE="http://eodev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/eodev/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc "${S}"/{AUTHORS,CHANGELOG,NEWS,README,THANKS,ToDo}
+
+ if use doc ; then
+ dohtml "${S}"/tutorial/*
+ fi
+}
diff --git a/sci-libs/eo/metadata.xml b/sci-libs/eo/metadata.xml
new file mode 100644
index 0000000..3b9d82a
--- /dev/null
+++ b/sci-libs/eo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>anthoine.bourgeois@gmail.com</email>
+ <name>Anthoine Bourgeois</name>
+ <description>aluco's overlay maintainer</description>
+ </maintainer>
+ <longdescription>
+ EO can easily design evolutionary algorithms that will find solutions to
+ virtually all kind of hard optimization problems, from continuous to
+ combinatorial ones.
+ </longdescription>
+</pkgmetadata>