summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/netvfy/Manifest6
-rw-r--r--net-misc/netvfy/files/netvfy-agent.conf6
-rw-r--r--net-misc/netvfy/files/netvfy-agent.rc14
-rw-r--r--net-misc/netvfy/files/netvfy-agent.service12
-rw-r--r--net-misc/netvfy/files/netvfy-agent.service.conf10
-rw-r--r--net-misc/netvfy/metadata.xml13
-rw-r--r--net-misc/netvfy/netvfy-9999.ebuild56
7 files changed, 117 insertions, 0 deletions
diff --git a/net-misc/netvfy/Manifest b/net-misc/netvfy/Manifest
new file mode 100644
index 0000000..08410f7
--- /dev/null
+++ b/net-misc/netvfy/Manifest
@@ -0,0 +1,6 @@
+AUX netvfy-agent.conf 164 BLAKE2B f79f3b238eb9c9d62c083ec4f6451aeaa7160c7a1ef554eac9b218341a7fa867e42106e722b3a398b8cb30f1e0a74d762ef2f2d1f3ccab564b1896ff4d873bab SHA512 f019353b1b54592c21e5dae3c647ba5cd0ea5d2e14ee19300cab5d4cdc9187325a0febf15906965d43e64e88d0801a6689a6c278003c1c0e8197247cdef174b6
+AUX netvfy-agent.rc 332 BLAKE2B 5b48f9efa451f333a8c98fd5e5669e0425f89c458b2ec9d47b7f166dc986b732eb0d707a2a2f914ff693383ee771f6d0d6cf7dc0550b90cefb92a4396da37dd0 SHA512 57cebddd15721f33d1ea33dc937c29177ef8633d780e7eefc1a92d32d35ea5944e056443bf3573a05f8d62938d50c4cfd4848bcbbe74a74a487d82d37297c2bb
+AUX netvfy-agent.service 220 BLAKE2B cd576233e102237e25bade17ac754f087c06270043daef7458b6842b45b6647edcaf744be5513e2c19fcda4aa06968629857f35b66923cb666a599ff259f9ffe SHA512 548c5cb931039f9b5a9e6dc879d83bb22abf85cb1091509f85089a1a04ef3db3f7359dd8f39cb712b063356bd4c2a7ff2e3758234791bad6a1d54aa76fc55617
+AUX netvfy-agent.service.conf 323 BLAKE2B 6a7d92887a33c16798358eafffd97dbad5475b4e472a4131d3e84bf8821275f64eeafb00404cf484958f20a08f16885bee25ff63eb73344e7773fcd9e18aef58 SHA512 5b7468329497dc9345848c96ccb458a365a0558ccd35a0df843bf8ef0683228b9981bc90a4fe06631d6fef94039612b8272867ac07f5e268c93806c59eb3b6a8
+EBUILD netvfy-9999.ebuild 1361 BLAKE2B 3ee57625f836f9bc5044317f696d944fb5d50512b56cc2be7cca146dfa0b822aaec6bd3c2efddb85c2764c0c20654afe57ea8f8589ec025bd8fb825c88490cb8 SHA512 f8eddb5a62d1cf0b11a7b09e2b63fd098804ccc09f77b632db53df4d38497f244a57e1ad1c9643788e691388338c806177e94d263a976fc8f57401228843d54e
+MISC metadata.xml 508 BLAKE2B 1ed5c8642816e61c13c6e169320b067c5c426d8df8bdd3320a3f59d8232498cda87395fecd7b717a41b90fcf9da2d7a56e23b165588c2c0e0eeba796ccd342e7 SHA512 95d454ad8195aae34d227e3bbb5c2a03cfa8de5649a15d38c3c8b11f1e910701ca85da88206f1dcb15badbd8b6e074ad23e6df88e669cb7192de55392f50772b
diff --git a/net-misc/netvfy/files/netvfy-agent.conf b/net-misc/netvfy/files/netvfy-agent.conf
new file mode 100644
index 0000000..94ebb01
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.conf
@@ -0,0 +1,6 @@
+# Config file for /etc/init.d/netvfy-agent
+
+# Specify the netvirt network name you want to connect to.
+# **NOTE** For a list see: netvfy-agent -l
+#
+NETWORK_NAME=""
diff --git a/net-misc/netvfy/files/netvfy-agent.rc b/net-misc/netvfy/files/netvfy-agent.rc
new file mode 100644
index 0000000..75bca14
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.rc
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="start a daemon to maintain a virtual connection using netvfy"
+
+command="netvfy-agent -c ${NETWORK_NAME}"
+command_background="true"
+pidfile="/var/run/${SVCNAME}.pid"
+
+depend() {
+ use net
+}
diff --git a/net-misc/netvfy/files/netvfy-agent.service b/net-misc/netvfy/files/netvfy-agent.service
new file mode 100644
index 0000000..2e045e6
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Netvfy Agent
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/netvfy-agent -c ${NETWORK_NAME}
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/netvfy/files/netvfy-agent.service.conf b/net-misc/netvfy/files/netvfy-agent.service.conf
new file mode 100644
index 0000000..fdce90f
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.service.conf
@@ -0,0 +1,10 @@
+# Config file for netvfy-agent
+
+# Specify the netvirt network name you want to connect to.
+# **NOTE** For a list see: netvfy-agent -l
+
+[Service]
+# if a user different from root should be use see
+# https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=netvfy-agent-git
+Environment="HOME=/root"
+Environment="NETWORK_NAME="
diff --git a/net-misc/netvfy/metadata.xml b/net-misc/netvfy/metadata.xml
new file mode 100644
index 0000000..8334684
--- /dev/null
+++ b/net-misc/netvfy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dominik.kriegner@gmail.com</email>
+ <name>Dominik Kriegner</name>
+ </maintainer>
+ <longdescription lang="en">
+ Netvfy is a network virtualization platform that allows you to create and
+ manage your own peer-to-peer virtual private network (VPN) with the goal to
+ keep it simple for everyone.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/netvfy/netvfy-9999.ebuild b/net-misc/netvfy/netvfy-9999.ebuild
new file mode 100644
index 0000000..c840d33
--- /dev/null
+++ b/net-misc/netvfy/netvfy-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3 systemd
+
+DESCRIPTION="create your own secure virtual network"
+HOMEPAGE="http://doc.netvfy.com"
+EGIT_REPO_URI="https://github.com/netvfy/netvfy-agent.git"
+EGIT_SUBMODULES=( '*' '-libconfig' )
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-libs/libconfig
+ dev-libs/openssl:=
+ dev-libs/jansson
+ dev-libs/libevent
+ net-nds/openldap
+ net-misc/curl[ssl]
+ sys-libs/zlib
+ sys-libs/glibc"
+DEPEND="${RDEPEND}
+ dev-util/scons
+ dev-util/cmake"
+
+src_configure() {
+ local mycmakeargs=( -DWITH_GUI=no )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cd tapcfg
+ scons
+ cd ..
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ systemd_newunit "${FILESDIR}/netvfy-agent.service" netvfy-agent.service
+ systemd_install_serviced "${FILESDIR}/netvfy-agent.service.conf"
+ newinitd "${FILESDIR}/netvfy-agent.rc" netvfy-agent
+ newconfd "${FILESDIR}/netvfy-agent.conf" netvfy-agent
+}
+
+pkg_postinst() {
+ elog "Read https://doc.netvfy.com to get started. In particular"
+ elog "you will have to provision a network using netvfy-agent -k ... and"
+ elog "edit the config file in /etc/conf.d/netvirt-agent (OpenRC) or "
+ elog "/etc/systemd/system/netvfy (systemd) and enable the corresponding"
+ elog "service"
+}