summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/xrayutilities/Manifest6
-rw-r--r--sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild (renamed from sci-physics/xrayutilities/xrayutilities-1.5.4.ebuild)14
-rw-r--r--sci-physics/xrayutilities/xrayutilities-9999.ebuild9
3 files changed, 15 insertions, 14 deletions
diff --git a/sci-physics/xrayutilities/Manifest b/sci-physics/xrayutilities/Manifest
index 99ed97c..3b976fa 100644
--- a/sci-physics/xrayutilities/Manifest
+++ b/sci-physics/xrayutilities/Manifest
@@ -1,4 +1,4 @@
-DIST xrayutilities-1.5.4.tar.gz 14822671 BLAKE2B 3c77035bb2a4f20f7a299c14ea0fc345a7b5bb083b6171e01a4aa105907327a193e22e32e5aff683820374c9dc91c01e3ccea2017304fe466632a3f36c522872 SHA512 930ce1960fd40cfeb40301f1266ee51b31a0c5b4c4ea70b7c3e061d3dd0516deee8563b718511b541ba51bf02cabd60155baa6c7a7a222e2b14b18d5d35bc768
-EBUILD xrayutilities-1.5.4.ebuild 776 BLAKE2B fa9a832c7cb10313420638859c75d30fcf9aa014fc7e57a422e7e8ccaa56c4ff89867e17557c44986431eca5b9890d0ec0988e55d7aeaa608730ac4a052ab094 SHA512 158092c3ca3a937a051655da17a90ee647aee020511d6b28fec29047ce240fae488eaa5b528b22cd27be2142be0342a4962b4f8b18943e412727be5fa637ada6
-EBUILD xrayutilities-9999.ebuild 756 BLAKE2B 9ed71164a042e86cc21f5a3d629d4212c1e62380f3d2800fd2c545edec5bcf585056a9a16df132af0a525b034ed9871a4f1aa7a831322e2e75e02a85ad20b11f SHA512 30d286c280bdfd7b9716d7d7baa1418d132cd0f54172a9d680f562551ea4c7ce7e88a36461d1b7651bc1e9ca124fa534c1955e2ea87a01d611c004b685562242
+DIST xrayutilities-1.7.1.tar.gz 9110861 BLAKE2B be1207128cb8d42346896ee701edef4a57be6e9fc2fc2108147ab87f73007b1a7560cc161e18f7a3f2dd2575feb7ed18607b0d9955fa6cc1ffdf2cc1faffe7b7 SHA512 9900471c2b7c001455504a4b2d50817455cb0de93f40dc9d993fbab5d3bf0af0401225b93448a1c806c4adfa8fc39f636c45376f535fd6b1f9f001141c529898
+EBUILD xrayutilities-1.7.1.ebuild 728 BLAKE2B 3437b63565f025a3390b27c4136d5bbeccd3131c9b4ab1f6e32ebac8863cb058425f5862b84a092e5a72a7f480fe52c3788ec91eca76566f18ea1e29955e0b80 SHA512 d9030542fd7fdb536ed2f7e6f44192adecb20836351ac809fccf960fc7dc842da2ec8f846be85e870f7243843909908823965cd6831a3e333362795cf4c13629
+EBUILD xrayutilities-9999.ebuild 749 BLAKE2B 087490d05c3d8821db4f18234d6a4a4e8f3de00d5b42104e6fae710f4aeb6d6fbf23aad4dac00664b4b7a8cda564c8c91c580b2fd59e36e13eeb852ea5b044f7 SHA512 6aa7c94c02153836c2fb76f00e65db4ed001ac01dfb782757661bd3f1fb45c355a87224a9d8dabbb75ef7eb88778a72c0fd60d0dfc053e449d5808ea8a2f2e40
MISC metadata.xml 505 BLAKE2B ddb2eb3e96e16a74726c1b88b84c778dd35569ecae6616d08a065ff661ff0b64bf10ba26c3b64c316fa350c7fd27ca53e6e71d33dd26e5d02abc05d9168c77d5 SHA512 2abbae8c730fd89e50de606cecd87d6bf77bc3f55357a4b9f5e63d32871bf26088fe95711779a4b28b6ff889270a4680dcac59482fdab0c5b4d51ee695f922a3
diff --git a/sci-physics/xrayutilities/xrayutilities-1.5.4.ebuild b/sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild
index b5cc36b..a701fc6 100644
--- a/sci-physics/xrayutilities/xrayutilities-1.5.4.ebuild
+++ b/sci-physics/xrayutilities/xrayutilities-1.7.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9} )
inherit distutils-r1
@@ -18,12 +18,12 @@ IUSE="openmp test"
DEPEND=">=dev-python/numpy-1.9
>=dev-python/scipy-0.13.0
- dev-python/h5py
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/h5py"
RDEPEND="${DEPEND}
- >sys-devel/gcc-4.2:*[openmp?]"
+ >sys-devel/gcc-4.2:*[openmp?]
+ test? ( dev-python/pytest )"
-DOCS=( README.md CHANGES.txt xrayutilities.pdf )
+DOCS=( README.md CHANGES.txt )
python_configure_all() {
if ! use openmp; then
@@ -32,5 +32,5 @@ python_configure_all() {
}
python_test() {
- $PYTHON setup.py test || die
+ py.test -v
}
diff --git a/sci-physics/xrayutilities/xrayutilities-9999.ebuild b/sci-physics/xrayutilities/xrayutilities-9999.ebuild
index 4d47b7f..3f9a798 100644
--- a/sci-physics/xrayutilities/xrayutilities-9999.ebuild
+++ b/sci-physics/xrayutilities/xrayutilities-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,9 +20,10 @@ RDEPEND=">=dev-python/numpy-1.9
>=dev-python/scipy-0.13.0
dev-python/h5py"
DEPEND="${RDEPEND}
- >sys-devel/gcc-4.2:*[openmp?]"
+ >sys-devel/gcc-4.2:*[openmp?]
+ test? ( dev-python/pytest )"
-DOCS=( README.md CHANGES.txt xrayutilities.pdf )
+DOCS=( README.md CHANGES.txt )
python_configure_all() {
if ! use openmp; then
@@ -31,5 +32,5 @@ python_configure_all() {
}
python_test() {
- $PYTHON setup.py test || die
+ py.test -v
}