summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@ndyk.de>2017-02-03 14:28:41 +0100
committerandy <andy@ndyk.de>2017-02-03 14:28:41 +0100
commit36d4eb46f29fa92a2f9da25c28bec80e6c5ca2da (patch)
treed09d660907c020dc3d111a84a1b1d1d9ae7d6653 /app-admin
parentadded gopass-1.0.0 (diff)
downloadandy-36d4eb46f29fa92a2f9da25c28bec80e6c5ca2da.tar.gz
andy-36d4eb46f29fa92a2f9da25c28bec80e6c5ca2da.tar.bz2
andy-36d4eb46f29fa92a2f9da25c28bec80e6c5ca2da.zip
gopass: added bash/zsh completion, git snapshot and test useflags
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gopass/Manifest3
-rw-r--r--app-admin/gopass/gopass-1.0.0.ebuild44
-rw-r--r--app-admin/gopass/gopass-9999.ebuild50
3 files changed, 81 insertions, 16 deletions
diff --git a/app-admin/gopass/Manifest b/app-admin/gopass/Manifest
index 733794a..d117880 100644
--- a/app-admin/gopass/Manifest
+++ b/app-admin/gopass/Manifest
@@ -1,3 +1,4 @@
DIST gopass-1.0.0.tar.gz 718426 SHA256 5b4df3f6278d9e95ead00af1f3899e9e83455353bebe444c6fdf521a3d01a097 SHA512 d690dfc027d792b1d478610e3ab59f52a9fb631a30b932f48defd3cdf99547e51ced78cc188b592c7f3e0b15975bd6e510fb2de2a049daf63ee482711e202439 WHIRLPOOL cd137aa261b738ad0717c0d184fe88b605018546a7f845252930e053df34b755f2031c577116c0da45a753a2d2954484d80143b8ae85346df392e7c457e0cb78
-EBUILD gopass-1.0.0.ebuild 741 SHA256 b5584b9f85d884c4fa94351a13321b2383880204ba13a7111a74e41415d22ad6 SHA512 02d3ed8bd10851884de8b791a1b18e8bcf8fa4d37dfd08302dd51fb3f03cacc6342c2a3d9ff6b5f35ab408ea3b2e31c12efb27fd940af4770cd8caa8c1fc5382 WHIRLPOOL f39a197c3acf1a0c926002cf1a30be950a39684bc42982943b0e7ebe0a87141dce5113979ef38c152ba4b80366bca9ff23b5ea4897eacea78966c994f4ff5a87
+EBUILD gopass-1.0.0.ebuild 1093 SHA256 f1807aed962ea37532546159146b35ff66cb7cfae462791cbd3aa6134d3b3057 SHA512 9a8a4892684ef229be01d06de2dcd26416f843f567cdd4df0f579292fbc9605bd8a822050f86aa3e16f4aa66bbb2f8bedb9fb912607b9dc45835939e44d0ff46 WHIRLPOOL 56034f1e9aeab0e6ebfe155e0fc9a9c5256fa0786553af3dd83146b7260b364ce6e5af3bda5a5c3313b9f82723862a2174a5252bd290df0e92ce0fad8898f007
+EBUILD gopass-9999.ebuild 1093 SHA256 f1807aed962ea37532546159146b35ff66cb7cfae462791cbd3aa6134d3b3057 SHA512 9a8a4892684ef229be01d06de2dcd26416f843f567cdd4df0f579292fbc9605bd8a822050f86aa3e16f4aa66bbb2f8bedb9fb912607b9dc45835939e44d0ff46 WHIRLPOOL 56034f1e9aeab0e6ebfe155e0fc9a9c5256fa0786553af3dd83146b7260b364ce6e5af3bda5a5c3313b9f82723862a2174a5252bd290df0e92ce0fad8898f007
MISC metadata.xml 618 SHA256 3dce4f82dc34dd1e081707b7c4f451e64aec45b7926c6c9d55a4b42403cc4208 SHA512 8426972607b6d6bcca83dcce41e3a9def8f858901878a2c4fc456bfad2948ef3eadac96d8359f8469675aa3496dae572795f6ae1c007d43d08139816d71c42a7 WHIRLPOOL 0c8411f00620be3bc3e5d4b74d8efd6e833153aa7da3df7b5d2fd16f43e5c53b6ebce4334e3131f6cd43e6d5c43548b075275edcdfafd63291a7883efb8d27b0
diff --git a/app-admin/gopass/gopass-1.0.0.ebuild b/app-admin/gopass/gopass-1.0.0.ebuild
index 476a1d6..014f262 100644
--- a/app-admin/gopass/gopass-1.0.0.ebuild
+++ b/app-admin/gopass/gopass-1.0.0.ebuild
@@ -4,33 +4,47 @@
EAPI=6
-inherit golang-base
+inherit bash-completion-r1
-EGO_PN=github.com/justwatchcom/gopass
-EGIT_COMMIT="v${PV}"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+EGO_PN=github.com/justwatchcom/${PN}
+
+if [[ ${PV} == 9999 ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~x86 ~arm"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
DESCRIPTION="The team password manager. Written in Go."
HOMEPAGE="https://www.justwatch.com/gopass"
LICENSE="MIT"
-RESTRICT="test"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="X"
-DEPEND=""
+IUSE="X zsh-completion test"
+DEPEND=">=dev-lang/go-1.6:="
RDEPEND="
app-crypt/gnupg
X? ( x11-misc/xclip )
+ zsh-completion? ( app-shells/gentoo-zsh-completions )
dev-vcs/git
"
-DEPEND=">=dev-lang/go-1.6:="
-S="${WORKDIR}/src/${EGO_PN}"
-src_unpack() {
- mkdir -p "${S}" && cd "${S}" || die
- unpack ${A} && mv ${P}/* . || die
+src_compile() {
+ cd "${S}"/src/${EGO_PN} || die
+ GOPATH="${S}" LDFLAGS="" emake build || die
}
-src_compile() {
- GOPATH="${WORKDIR}" LDFLAGS="" emake build || die
+src_install() {
+ cd "${S}"/src/${EGO_PN} || die
+ emake DESTDIR="${D}" install
+ if use zsh-completion; then
+ emake zsh.completion || die
+ insinto /usr/share/zsh/site-functions
+ newins zsh.completion _${PN}
+ fi
+ emake bash.completion || die
+ newbashcomp bash.completion ${PN}
+ einstalldocs
}
+
diff --git a/app-admin/gopass/gopass-9999.ebuild b/app-admin/gopass/gopass-9999.ebuild
new file mode 100644
index 0000000..014f262
--- /dev/null
+++ b/app-admin/gopass/gopass-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+EGO_PN=github.com/justwatchcom/${PN}
+
+if [[ ${PV} == 9999 ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~x86 ~arm"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="The team password manager. Written in Go."
+HOMEPAGE="https://www.justwatch.com/gopass"
+LICENSE="MIT"
+SLOT="0"
+IUSE="X zsh-completion test"
+DEPEND=">=dev-lang/go-1.6:="
+RDEPEND="
+ app-crypt/gnupg
+ X? ( x11-misc/xclip )
+ zsh-completion? ( app-shells/gentoo-zsh-completions )
+ dev-vcs/git
+"
+
+src_compile() {
+ cd "${S}"/src/${EGO_PN} || die
+ GOPATH="${S}" LDFLAGS="" emake build || die
+}
+
+src_install() {
+ cd "${S}"/src/${EGO_PN} || die
+ emake DESTDIR="${D}" install
+ if use zsh-completion; then
+ emake zsh.completion || die
+ insinto /usr/share/zsh/site-functions
+ newins zsh.completion _${PN}
+ fi
+ emake bash.completion || die
+ newbashcomp bash.completion ${PN}
+ einstalldocs
+}
+