summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/sxlock/Manifest2
-rw-r--r--x11-misc/sxlock/files/sxlock-1.1-red-background.patch18
2 files changed, 3 insertions, 17 deletions
diff --git a/x11-misc/sxlock/Manifest b/x11-misc/sxlock/Manifest
index cc782f2..054ad84 100644
--- a/x11-misc/sxlock/Manifest
+++ b/x11-misc/sxlock/Manifest
@@ -1,4 +1,4 @@
-AUX sxlock-1.1-red-background.patch 1272 BLAKE2B ef3dbfa5347f80e3d34e2a56f86e372483064e78c2122a10ba70f87897f67b491d610a91ac2b730affd59225ed0fe0af8fe227e25d6226bf2bde756eac56df6d SHA512 96d8288298ab68cee428691c37e0773b323dc4246e8e7f78769f546cca3d65fe62b781a6f65756fc98535775e76327b92f14081a60b2c7fe328a66341d7ed75b
+AUX sxlock-1.1-red-background.patch 434 BLAKE2B 651f04d1d1b4cd08ff9dd2610d0b5c02cf03e667696b09e917ff5be13a6a97147620050732e20a8bc9a66110f40454e5bb1558addda8970b575e589d3bfd9e39 SHA512 02641bc29037c6f90c1febd70ba96ea2816403d8e828183ce0ddd3b5a446da557f02ef30397e818cce72f0defebd5bfe55988b282083bb1d7011d73731434186
DIST sxlock-1.1.tar.gz 7139 BLAKE2B 312e1b6b0d50a91e611ad5537df66991dd2377580aa371773dec1b6e1f3663a0361b99faab3abdffebb5c8d9352be5d576f47d02db42e3734e975a30111e6102 SHA512 8f6b7ebab103163200d6e7453274edba5003e1fd0ed487fb7f779186c46dd051d7f38c26b7bfacb45265396a46a53aa227863e1f088d3231a2191a58c2308538
EBUILD sxlock-1.1-r1.ebuild 557 BLAKE2B 28d354eb001a953928fa73f07fb52ba73260aed2657f59ca972d2feb0fb15aa28c43e3b9b4e7658b8c85b79b4f8015f02d3e497a1471e31de2b3d6f9adef0696 SHA512 fe07e7de386ba0ea38cad74f2ca9a7f40e710ef2bff34f7f21c311a9d122001f22495bed26f80fa1f7c28fd41a9f76d500d6fe845c3627ae9e1a3d71d6fe4a30
MISC metadata.xml 241 BLAKE2B 117f3b263452b334f3adb70c3f15267e64b13d7335f35f84ead1de216b9f53a026ee25340525995e80ca4fd6cabdd101cd3f7563b0babae98d6c12806b4e664b SHA512 4fd289d5889d95606c00514daf808a41d37c998c80c21fed5337cd259ef3605c14dd75186bedfd1b5abed98fcb590232553332468cb218cddcc7c089af81bc76
diff --git a/x11-misc/sxlock/files/sxlock-1.1-red-background.patch b/x11-misc/sxlock/files/sxlock-1.1-red-background.patch
index 8ba0001..e1d02d8 100644
--- a/x11-misc/sxlock/files/sxlock-1.1-red-background.patch
+++ b/x11-misc/sxlock/files/sxlock-1.1-red-background.patch
@@ -1,22 +1,8 @@
diff --git a/sxlock.c b/sxlock.c
-index ca195d5..cc1f872 100644
+index ca195d5..9670eac 100644
--- a/sxlock.c
+++ b/sxlock.c
-@@ -195,9 +195,10 @@ main_loop(Window w, GC gc, XFontStruct* font, WindowPositionInfo* info, char pas
- /* draw new passdisp or 'auth failed' */
- if (failed) {
- x = base_x - XTextWidth(font, "authentication failed", 21) / 2;
-- XSetForeground(dpy, gc, red.pixel);
-- XDrawString(dpy, w, gc, x, base_y + ascent + 20, "authentication failed", 21);
-- XSetForeground(dpy, gc, white.pixel);
-+ XSetWindowBackground(dpy, w, red.pixel);
-+ //XSetForeground(dpy, gc, red.pixel);
-+ //XDrawString(dpy, w, gc, x, base_y + ascent + 20, "authentication failed", 21);
-+ //XSetForeground(dpy, gc, white.pixel);
- } else {
- int lendisp = len;
- if (hidelength && len > 0)
-@@ -321,7 +322,7 @@ main(int argc, char** argv) {
+@@ -321,7 +321,7 @@ main(int argc, char** argv) {
/* set default values for command-line arguments */
opt_passchar = "*";