summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gopass/gopass-9999.ebuild')
-rw-r--r--app-admin/gopass/gopass-9999.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-admin/gopass/gopass-9999.ebuild b/app-admin/gopass/gopass-9999.ebuild
deleted file mode 100644
index 47b0643..0000000
--- a/app-admin/gopass/gopass-9999.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit bash-completion-r1
-
-EGO_PN=github.com/justwatchcom/${PN}
-
-if [[ ${PV} == 9999 ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~x86 ~arm"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="The team password manager. Written in Go."
-HOMEPAGE="https://www.justwatch.com/gopass"
-LICENSE="MIT"
-SLOT="0"
-IUSE="X zsh-completion test symlink"
-DEPEND=">=dev-lang/go-1.6:="
-RDEPEND="
- app-crypt/gnupg
- X? ( x11-misc/xclip )
- zsh-completion? ( app-shells/gentoo-zsh-completions )
- dev-vcs/git
- symlink? ( !app-admin/pass )
-"
-
-src_compile() {
- cd "${S}"/src/${EGO_PN} || die
- GOPATH="${S}" LDFLAGS="" emake build || die
-}
-
-src_install() {
- cd "${S}"/src/${EGO_PN} || die
- emake DESTDIR="${D}" install
- if use zsh-completion; then
- emake zsh.completion || die
- insinto /usr/share/zsh/site-functions
- newins zsh.completion _${PN}
- fi
- emake bash.completion || die
- newbashcomp bash.completion ${PN}
- einstalldocs
-
- if use symlink ; then
- dosym gopass /usr/bin/pass
- fi
-}
-