summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/thinkfan/thinkfan-0.7.1.ebuild')
-rw-r--r--sys-apps/thinkfan/thinkfan-0.7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/thinkfan/thinkfan-0.7.1.ebuild b/sys-apps/thinkfan/thinkfan-0.7.1.ebuild
new file mode 100644
index 0000000..01893cd
--- /dev/null
+++ b/sys-apps/thinkfan/thinkfan-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A minimalist fan control program. Supports the sysfs hwmon
+interface and thinkpad_acpi"
+HOMEPAGE="http://http://thinkfan.sourceforge.net"
+SRC_URI="http://downloads.sourceforge.net/project/thinkfan/thinkfan-$PV.tar.gz"
+
+LICENSE="Creative Commons Attribution-Share Alike 3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dosbin thinkfan
+
+ exeinto /etc/init.d
+ newexe rcscripts/thinkfan.gentoo thinkfan
+
+ dodoc README thinkfan.conf.sysfs thinkfan.conf.thinkpad ChangeLog || die
+ if ! [[ -f /proc/acpi/ibm/fan ]]; then
+ elog "thinkpad_acpi procfs entries don't seem to exist." \
+ "You'll need to use the generic sysfs hwmon interface. See README."
+ else
+ elog "This seems to be a Thinkpad. You should use the IBM" \
+ "interface. See README."
+ fi
+ elog "If you're upgrading from <=thinkfan-0.4, you'll have" \
+ "to delete /var/run/thinkfan.pid."
+}