summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/autorandr')
-rw-r--r--x11-misc/autorandr/Manifest1
-rw-r--r--x11-misc/autorandr/autorandr-9999.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
new file mode 100644
index 0000000..8f13cf6
--- /dev/null
+++ b/x11-misc/autorandr/Manifest
@@ -0,0 +1 @@
+EBUILD autorandr-9999.ebuild 844 SHA256 388482afbff03af656a7cdf19214d4175bd45aa5ef5443ea8d298cd5b7d176bd SHA512 eea0170c0d38523a55baf3feaf13c1326e5c55bb8db5f2f7edb342117ef083eb9d84493eaa7a69edcc653379713ef4996f9a02347624aded4a3fceb749f20b58 WHIRLPOOL 00d58701303acf716e14241b5f82f0bb172fba596e5559a8b02814490a67ed7544bbd98abc61e3f747dbf1e3170af4ee5dd1b24ce0fac5cc2d329364bfc2d93d
diff --git a/x11-misc/autorandr/autorandr-9999.ebuild b/x11-misc/autorandr/autorandr-9999.ebuild
new file mode 100644
index 0000000..f564e56
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-2 bash-completion-r1 udev
+
+DESCRIPTION="Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr or disper"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+SRC_URI=""
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS=""
+IUSE="udev +pm-utils"
+
+DEPEND="udev? ( virtual/udev )
+ pm-utils? ( sys-power/pm-utils )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ exeinto /usr/bin
+ doexe auto-disper
+ doexe autorandr
+ dodoc README.md
+
+ newbashcomp bash_completion/${PN} ${PN}
+
+ if use udev; then
+ udev_dorules udev/40-monitor-hotplug.rules
+ fi
+
+ if use pm-utils; then
+ exeinto /usr/lib/pm-utils/sleep.d
+ doexe pm-utils/40autorandr
+ fi
+}
+
+pkg_postinst() {
+ udev_reload
+}
+