summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/mimeo/mimeo-2013.4.ebuild')
-rw-r--r--x11-misc/mimeo/mimeo-2013.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/mimeo/mimeo-2013.4.ebuild b/x11-misc/mimeo/mimeo-2013.4.ebuild
new file mode 100644
index 0000000..afbd5d5
--- /dev/null
+++ b/x11-misc/mimeo/mimeo-2013.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+PYTHON_DEPEND="2"
+
+inherit distutils python
+
+DESCRIPTION="Open files using MIME-type associations."
+HOMEPAGE="http://xyne.archlinux.ca/projects/mimeo"
+SRC_URI="http://xyne.archlinux.ca/projects/mimeo/src/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/file dev-python/pyxdg"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ python_convert_shebangs -r 2 .
+ distutils_src_install
+
+ dobin ${PN}
+}