summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2013-02-21 14:40:45 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2013-02-21 14:40:45 +0100
commit20075ff8d872f4d756646adc1fa447c466493494 (patch)
treeeb68d069c5b78429db2643ea407337fbe22cfa4f
parentRemove nss-myhostname (diff)
downloadbenf-20075ff8d872f4d756646adc1fa447c466493494.tar.gz
benf-20075ff8d872f4d756646adc1fa447c466493494.tar.bz2
benf-20075ff8d872f4d756646adc1fa447c466493494.zip
Add user-session-units ebuild for systemd user sessions
And the xorg-launch-helper dependency as well.
-rw-r--r--sys-apps/user-session-units/Manifest1
-rw-r--r--sys-apps/user-session-units/user-session-units-9999.ebuild38
-rw-r--r--sys-apps/xorg-launch-helper/Manifest1
-rw-r--r--sys-apps/xorg-launch-helper/xorg-launch-helper-9999.ebuild30
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-apps/user-session-units/Manifest b/sys-apps/user-session-units/Manifest
new file mode 100644
index 0000000..2a09902
--- /dev/null
+++ b/sys-apps/user-session-units/Manifest
@@ -0,0 +1 @@
+EBUILD user-session-units-9999.ebuild 928 SHA256 d1f26a4ea79384a3906c0ce07e06e6c3e4fcd2a7b420a29d263d679a967dee45 SHA512 db0984c8ad05c58fe08670cc9c708992c06095c62382e83da91a0feb171b08e8d5247c8cb11c2c784891f4e5658a305fcd35d4121055f07eb726cebee152155a WHIRLPOOL b9576c153a9cde27a6e88264c85de7b7b4d3b3d8e1d4e677e56362093edbc8d5ffe4331f78b6c40056ccee06e8c4e5ae6e218648bad37cd820e83b74141ed746
diff --git a/sys-apps/user-session-units/user-session-units-9999.ebuild b/sys-apps/user-session-units/user-session-units-9999.ebuild
new file mode 100644
index 0000000..dcbd678
--- /dev/null
+++ b/sys-apps/user-session-units/user-session-units-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="https://github.com/sofar/user-session-units.git"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils linux-info systemd git-2
+
+DESCRIPTION="A collection of units for the systemd user session"
+HOMEPAGE="https://github.com/sofar/user-session-units"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/systemd
+ sys-apps/xorg-launch-helper"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # FIXME: configure script doesnt handle systemd{system,user}unitdir..
+ #local myeconfargs=(
+ # --with-systemdsystemunitdir="$(systemd_get_unitdir)"
+ # --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ #)
+ # FIXME: example services installation is completely automagic..
+ autotools-utils_src_configure
+}
+
+pkg_pretend() {
+ local CONFIG_CHECK="~MEMCG"
+ check_extra_config
+}
diff --git a/sys-apps/xorg-launch-helper/Manifest b/sys-apps/xorg-launch-helper/Manifest
new file mode 100644
index 0000000..84df23e
--- /dev/null
+++ b/sys-apps/xorg-launch-helper/Manifest
@@ -0,0 +1 @@
+EBUILD xorg-launch-helper-9999.ebuild 658 SHA256 6ab2aa04c9b00c7bdd38d423b2180d0fb509358b7a0eeb45f5922ed2bd2cebc8 SHA512 a85a345cad52f9a6f72c427f98970a3efbc51aa1c282de9ddad45a45a9ed7ce0c39250eac6539d57cbb172d4d4d995dd5246a72c26f6c9548f956af5f2e4ae23 WHIRLPOOL cf26c9aa8e972488316ece36aaa31d32a8cdcc9e5742bb95fe48dead92557bd20289f0d007f142ab0017f87f97d322d668ea671b64c06a39d8340a48943d0324
diff --git a/sys-apps/xorg-launch-helper/xorg-launch-helper-9999.ebuild b/sys-apps/xorg-launch-helper/xorg-launch-helper-9999.ebuild
new file mode 100644
index 0000000..5bf8efc
--- /dev/null
+++ b/sys-apps/xorg-launch-helper/xorg-launch-helper-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="https://github.com/sofar/xorg-launch-helper.git"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils systemd git-2
+
+DESCRIPTION="A wrapper in C to make XOrg function as a proper systemd unit"
+HOMEPAGE="https://github.com/sofar/xorg-launch-helper"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="sys-apps/systemd
+ x11-base/xorg-server"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ )
+ autotools-utils_src_configure
+}