summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/sword/Manifest2
-rw-r--r--app-text/sword/sword-1.7.2.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/app-text/sword/Manifest b/app-text/sword/Manifest
new file mode 100644
index 0000000..d4a8bbe
--- /dev/null
+++ b/app-text/sword/Manifest
@@ -0,0 +1,2 @@
+DIST sword-1.7.2.tar.gz 2127944 SHA256 ac7aace0ecb7a405d4b4b211ee1ae5b2250bb5c57c9197179747c9e830787871 SHA512 1ee9565f36d113c9b21883a78004e895ab2f74d9c9f1909058c204e38647a96938de2e544a68858d2c4b048b67ba868049c1c09f0067bc9819a5a85f75285ebe WHIRLPOOL 894e4d96b2ff61ac19de853ff6b17aa2279fb7b5b571c1030ba18daefbea8997bd61d386ff3a1dff49d997c69d6acf2a83094ad6ec5c593acca3dc7fb1d488a0
+EBUILD sword-1.7.2.ebuild 2241 SHA256 9bba0386459ed3dffc85e80345e33afed639f33d15bbc4f3ae57b04de704c4e8 SHA512 2a7dc6d952cbfdd21cf1ac3f654b9fa900cdce50a8d3be0a81ea3ddd2a35644cbb536864a4cac5849d5837570fb901edc16e831155e37b368dd099b25d088474 WHIRLPOOL fbbd33ed005efe1085053fb9aaec6e02ae4a4b187c6cc73308a6e584cb3f153db84ba5eb4db36a35e95301f41332e734a27a7dcd11bf1f43c70b421f097407e1
diff --git a/app-text/sword/sword-1.7.2.ebuild b/app-text/sword/sword-1.7.2.ebuild
new file mode 100644
index 0000000..46304ba
--- /dev/null
+++ b/app-text/sword/sword-1.7.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Copyright 2014 The BibleTime team
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Library for Bible reading software."
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/${PN}/source/v${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="clucene curl examples icu internal-zlib static-libs test utils zlib"
+REQUIRED_USE="^^ ( internal-zlib zlib )"
+
+CMAKE_MIN_VERSION=2.6.0
+RDEPEND="
+ clucene? ( dev-cpp/clucene )
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog CODINGSTYLE LICENSE NEWS README"
+
+pkg_setup() {
+ einfo "Please file bugs for this ebuild to http://bugs.bibletime.info/"
+}
+
+src_prepare() {
+ sed -i -e '/CMAKE_C_FLAGS/d' -e '/CMAKE_CXXFLAGS/d' CMakeLists.txt || die
+
+ cat <<-EOF > "${T}"/${PN}.conf
+[Install]
+DataPath=${EPREFIX}/usr/share/${PN}/
+EOF
+}
+
+src_configure() {
+ local mycmakeargs=()
+ use static-libs || mycmakeargs+=( -DLIBSWORD_LIBRARY_TYPE=Shared )
+ use clucene || mycmakeargs+=( -DSWORD_NO_CLUCENE=Yes )
+ use curl || mycmakeargs+=( -DSWORD_NO_CURL=Yes )
+ use examples && mycmakeargs+=( -DSWORD_BUILD_EXAMPLES=Yes )
+ use icu || mycmakeargs+=( -DSWORD_NO_ICU=No ) # Bug with <=sword-1.7.2
+ use internal-zlib && mycmakeargs+=( -DSWORD_USE_INTERNAL_ZLIB=No )
+ use test && mycmakeargs+=( -DSWORD_BUILD_TESTS=Yes )
+ use utils || mycmakeargs+=( -DSWORD_BUILD_UTILS=No )
+ use zlib || use internal-zlib || mycmakeargs+=( -DSWORD_NO_ZLIB=Yes )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+# find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use examples; then
+ rm -rf examples/.cvsignore
+ rm -rf examples/cmdline/.cvsignore
+ rm -rf examples/cmdline/.deps
+ cp -R samples examples "${ED}"/usr/share/doc/${PF}/
+ fi
+
+ insinto /etc
+ doins "${T}"/${PN}.conf
+}
+
+pkg_postinst() {
+ elog "Check out http://www.crosswire.org/sword/modules/"
+ elog "to download modules that you would like to use with SWORD."
+ elog "Follow module installation instructions found on"
+ elog "the web or in ${EROOT}/usr/share/doc/${PF}/"
+}