summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Carreira <jfmcarreira@gmail.com>2020-11-25 19:38:32 +0000
committerJoao Carreira <jfmcarreira@gmail.com>2020-11-25 19:38:32 +0000
commit47eb9963e309ad6831deb081fcc573ad386c9662 (patch)
treed9c6324310162c988e7bb24ad71d27465a133c95
parentapp-text/kbibtex: remove ebuilds (diff)
downloadcarreira-47eb9963e309ad6831deb081fcc573ad386c9662.tar.gz
carreira-47eb9963e309ad6831deb081fcc573ad386c9662.tar.bz2
carreira-47eb9963e309ad6831deb081fcc573ad386c9662.zip
media-gfx/ktikz: Update 9999 ebuild
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Joao Carreira <jfmcarreira@gmail.com>
-rw-r--r--media-gfx/ktikz/ktikz-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/media-gfx/ktikz/ktikz-9999.ebuild b/media-gfx/ktikz/ktikz-9999.ebuild
index 01e7180..4b62443 100644
--- a/media-gfx/ktikz/ktikz-9999.ebuild
+++ b/media-gfx/ktikz/ktikz-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils cmake-utils qmake-utils git-r3 xdg
+inherit eutils cmake qmake-utils git-r3 xdg
DESCRIPTION="A QT5-based editor for the TikZ language"
HOMEPAGE="http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language"
@@ -12,7 +12,7 @@ SLOT="5"
KEYWORDS=""
IUSE="kde +doc -debug"
-EGIT_REPO_URI="https://github.com/jfmcarreira/ktikz.git"
+EGIT_REPO_URI="https://github.com/fhackenberger/ktikz.git"
DEPEND="
dev-qt/qtcore:5
@@ -40,12 +40,15 @@ DOCS="Changelog TODO"
src_prepare() {
# correct the qcollectiongenerator binary
sed -ie 's%#QCOLLECTIONGENERATORCOMMAND = qcollectiongenerator%QCOLLECTIONGENERATORCOMMAND = /usr/lib/qt5/bin/qcollectiongenerator%g' qmake/qtikzconfig.pri || die
- eapply_user
+# eapply_user
+ if use kde; then
+ cmake_src_prepare
+ fi
}
src_configure() {
if use kde; then
- cmake-utils_src_configure
+ cmake_src_configure
else
KDECONFIG="CONFIG-=usekde"
eqmake5 qtikz.pro "CONFIG+=nostrip" "$KDECONFIG"
@@ -57,7 +60,7 @@ src_compile() {
cmake_comment_add_subdirectory doc
fi
if use kde; then
- cmake-utils_src_compile
+ cmake_src_compile
else
emake
fi
@@ -65,7 +68,7 @@ src_compile() {
src_install() {
if use kde; then
- cmake-utils_src_install
+ cmake_src_install
else
emake INSTALL_ROOT="${D}" install
fi