summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Carreira <jfmcarreira@gmail.com>2016-11-08 18:43:33 +0000
committerJoao Carreira <jfmcarreira@gmail.com>2016-11-08 18:43:33 +0000
commit62522404fb2a3400268603f0ad2a0509525b5bf4 (patch)
tree29aa7dff302dc03baba54092e956e6721b22863e /media-video
parentAdd missing files (diff)
downloadcarreira-62522404fb2a3400268603f0ad2a0509525b5bf4.tar.gz
carreira-62522404fb2a3400268603f0ad2a0509525b5bf4.tar.bz2
carreira-62522404fb2a3400268603f0ad2a0509525b5bf4.zip
Fix overlay
Bugfix in media-video/playuver and remove old ebuilds
Diffstat (limited to 'media-video')
-rw-r--r--media-video/playuver/playuver-0.11.0.ebuild (renamed from media-video/playuver/playuver-0.8.0.ebuild)21
-rw-r--r--media-video/playuver/playuver-9999.ebuild20
2 files changed, 22 insertions, 19 deletions
diff --git a/media-video/playuver/playuver-0.8.0.ebuild b/media-video/playuver/playuver-0.11.0.ebuild
index efa6ea4..25891b5 100644
--- a/media-video/playuver/playuver-0.8.0.ebuild
+++ b/media-video/playuver/playuver-0.11.0.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
inherit eutils cmake-utils git-r3
DESCRIPTION="plaYUVer is an open-source QT based raw video player"
HOMEPAGE="https://github.com/pixlra/playuver"
+LICENSE="GPL-2"
EGIT_REPO_URI="https://github.com/pixlra/playuver.git"
EGIT_COMMIT="${PV}"
-LICENSE="GPL-2"
-SLOT="0"
+SLOT=0
KEYWORDS="~amd64"
-IUSE="+qt5 -qt4 ffmpeg opencv"
+
+X86_CPU_FEATURES="cpu_flags_x86_sse"
+IUSE="+qt5 -qt4 ffmpeg opencv -static-libs $X86_CPU_FEATURES"
DEPEND="
qt5? (
@@ -32,22 +34,23 @@ DEPEND="
dev-qt/qtdbus:4
)
ffmpeg? ( virtual/ffmpeg )
- opencv? ( qt5? ( media-libs/opencv[-qt4] ) !qt5? ( media-libs/opencv[-qt5] ) )
+ opencv? ( media-libs/opencv )
"
RDEPEND="${DEPEND}"
REQUIRED_USE="
?? ( qt5 qt4 )
+ qt4? ( !opencv )
"
-# S="${WORKDIR}/${PN}"
-
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_use qt4) # use qt5
+ $(cmake-utils_use_use cpu_flags_x86_sse SSE) # use SSE
+ $(cmake-utils_use_use qt4) # use qt4
$(cmake-utils_use_use ffmpeg) # support ffmpeg
$(cmake-utils_use_use opencv) # support opencv
+ $(cmake-utils_use_use static-libs STATIC) # build static libs
)
cmake-utils_src_configure
}
diff --git a/media-video/playuver/playuver-9999.ebuild b/media-video/playuver/playuver-9999.ebuild
index e446eed..a48469b 100644
--- a/media-video/playuver/playuver-9999.ebuild
+++ b/media-video/playuver/playuver-9999.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
inherit eutils cmake-utils git-r3
DESCRIPTION="plaYUVer is an open-source QT based raw video player"
HOMEPAGE="https://github.com/pixlra/playuver"
+LICENSE="GPL-2"
EGIT_REPO_URI="https://github.com/pixlra/playuver.git"
-EGIT_BRANCH="master"
-LICENSE="GPL-2"
-SLOT="0"
+SLOT=0
KEYWORDS=""
X86_CPU_FEATURES="cpu_flags_x86_sse"
@@ -21,26 +20,27 @@ IUSE="+qt5 -qt4 ffmpeg opencv -static-libs $X86_CPU_FEATURES"
DEPEND="
qt5? (
+ dev-qt/qtconcurrent:5
dev-qt/qtcore:5
+ dev-qt/qtdbus:5
dev-qt/qtgui:5
- dev-qt/qtwidgets:5
dev-qt/qtprintsupport:5
- dev-qt/qtdbus:5
- dev-qt/qtconcurrent:5
+ dev-qt/qtwidgets:5
)
qt4? (
+ dev-qt/qtdbus:4
dev-qt/qtcore:4
dev-qt/qtgui:4
- dev-qt/qtdbus:4
)
ffmpeg? ( virtual/ffmpeg )
- opencv? ( qt5? ( media-libs/opencv[-qt4] ) !qt5? ( media-libs/opencv[-qt5] ) )
+ opencv? ( media-libs/opencv )
"
RDEPEND="${DEPEND}"
REQUIRED_USE="
?? ( qt5 qt4 )
+ qt4? ( !opencv )
"
src_configure() {