summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/earlyoom/earlyoom-9999.ebuild')
-rw-r--r--sys-process/earlyoom/earlyoom-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/earlyoom/earlyoom-9999.ebuild b/sys-process/earlyoom/earlyoom-9999.ebuild
new file mode 100644
index 0000000..f840fde
--- /dev/null
+++ b/sys-process/earlyoom/earlyoom-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Early out-of-memory killer that runs in user-space"
+HOMEPAGE="https://github.com/rfjakob/earlyoom"
+
+EGIT_REPO_URI="https://github.com/rfjakob/earlyoom.git"
+EGIT_BRANCH="master"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DISTDDIR=$WORKDIR
+
+src_install() {
+ dobin earlyoom
+ doinitd "${FILESDIR}/earlyoom"
+}