summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'jquery-plugins/tablesorter/tablesorter-2.0.5.ebuild')
-rw-r--r--jquery-plugins/tablesorter/tablesorter-2.0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/jquery-plugins/tablesorter/tablesorter-2.0.5.ebuild b/jquery-plugins/tablesorter/tablesorter-2.0.5.ebuild
new file mode 100644
index 0000000..c480a3c
--- /dev/null
+++ b/jquery-plugins/tablesorter/tablesorter-2.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-3.2-r1.ebuild,v 1.10 2011/03/27 19:46:03 ranger Exp $
+
+EAPI="4"
+
+DESCRIPTION="tablesorter"
+HOMEPAGE="http://tablesorter.com/"
+SRC_URI="http://tablesorter.com/__jquery.tablesorter.zip -> ${P}.zip"
+
+IUSE=""
+LICENSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=js-libs/jquery-1.2.1"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack "${A}"
+ find -name .svn | xargs rm -fr
+}
+
+src_install() {
+ mkdir -p ${D}/usr/share/tablesorter/themes
+ cp ${WORKDIR}/jquery.tablesorter.js ${D}/usr/share/tablesorter/
+ cp -r ${WORKDIR}/themes/* ${D}/usr/share/tablesorter/themes/
+}