summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/anttweakbar')
-rw-r--r--media-libs/anttweakbar/Manifest2
-rw-r--r--media-libs/anttweakbar/anttweakbar-1.14.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/anttweakbar/Manifest b/media-libs/anttweakbar/Manifest
new file mode 100644
index 0000000..6a42c53
--- /dev/null
+++ b/media-libs/anttweakbar/Manifest
@@ -0,0 +1,2 @@
+DIST anttweakbar-1.14.zip 4354790 RMD160 6297484674785807a8e750ccc8934dcba35f8353 SHA1 b6405082efb6d6f26b3856a1b12c4e520055390e SHA256 606a2a7fc07d5acc42d0e81ccb8b7c59927faace4642a2091168c5f390b4cb2a
+EBUILD anttweakbar-1.14.ebuild 735 RMD160 b36386fee99754d42d2a2db765f9fe90ccb35648 SHA1 1371e1786746c01f09f05e001e147c34b4bb3237 SHA256 1ab5f0aaff75d353640a36698805fa23366d090c8b38af71a6520ad01c992b1d
diff --git a/media-libs/anttweakbar/anttweakbar-1.14.ebuild b/media-libs/anttweakbar/anttweakbar-1.14.ebuild
new file mode 100644
index 0000000..c2b1597
--- /dev/null
+++ b/media-libs/anttweakbar/anttweakbar-1.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+DESCRIPTION="A library that adds an easy GUI into OpenGL applications to interactively tweak them on-screen"
+HOMEPAGE="http://www.antisphere.com/Wiki/tools:anttweakbar?sb=tools"
+
+SRC_URI="http://www.antisphere.com/Tools/AntTweakBar/AntTweakBar?v -> ${P}.zip"
+
+KEYWORDS="~x86 ~amd64"
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="$DEPEND"
+
+S="${WORKDIR}/AntTweakBar"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd src
+ emake || die "${P} could not be compiled"
+}
+
+src_install() {
+ dolib lib/libAntTweakBar.so
+ dolib lib/libAntTweakBar.so.1
+ insinto /usr/include
+ doins include/AntTweakBar.h
+}