summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAnna Zubenko <sheela.na.geek@gmail.com>2012-05-24 14:07:55 +0300
committerAnna Zubenko <sheela.na.geek@gmail.com>2012-05-24 14:07:55 +0300
commita9faa3be5bf13f97d55f9318f0ebc7ee31935ced (patch)
tree31ac80d19ef320bd1e8a77017cc022de0ef57350 /net-im
parentfixed new working dir name (diff)
downloadeatnumber1-a9faa3be5bf13f97d55f9318f0ebc7ee31935ced.tar.gz
eatnumber1-a9faa3be5bf13f97d55f9318f0ebc7ee31935ced.tar.bz2
eatnumber1-a9faa3be5bf13f97d55f9318f0ebc7ee31935ced.zip
Removed live gajim ebuild
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/gajim-9999.ebuild107
1 files changed, 0 insertions, 107 deletions
diff --git a/net-im/gajim/gajim-9999.ebuild b/net-im/gajim/gajim-9999.ebuild
deleted file mode 100644
index c922dba..0000000
--- a/net-im/gajim/gajim-9999.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit eutils mercurial python multilib
-
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="sqlite xml"
-
-EHG_REPO_URI="http://hg.gajim.org/gajim"
-#EHG_REVISION="default"
-#EHG_BOOTSTRAP="./autogen.sh"
-
-DESCRIPTION="Jabber client written in PyGTK"
-HOMEPAGE="http://www.gajim.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="avahi crypt dbus gnome gmail idle jingle libnotify networkmanager nls spell srv X xhtml"
-
-COMMON_DEPEND="
- x11-libs/gtk+:2
- dev-python/pygtk:2"
-
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/gettext-0.17-r1
- >=dev-util/intltool-0.40.1
- dev-util/pkgconfig"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyopenssl
- crypt? (
- app-crypt/gnupg
- dev-python/pycrypto
- )
- dbus? (
- dev-python/dbus-python
- dev-libs/dbus-glib
- libnotify? ( dev-python/notify-python )
- avahi? ( net-dns/avahi[dbus,gtk,python] )
- )
- gnome? (
- dev-python/libgnome-python
- dev-python/gnome-keyring-python
- dev-python/egg-python
- )
- idle? ( x11-libs/libXScrnSaver )
- jingle? ( net-libs/farsight2[python] )
- networkmanager? (
- dev-python/dbus-python
- || ( >=net-misc/networkmanager-0.7.1 net-misc/networkmanager[gnome] )
- )
- srv? (
- || (
- dev-python/libasyncns-python
- net-dns/bind-tools )
- )
- spell? ( app-text/gtkspell )
- xhtml? ( dev-python/docutils )"
-
-pkg_setup() {
- if ! use dbus; then
- if use libnotify; then
- eerror "The dbus USE flag is required for libnotify support"
- die "USE=\"dbus\" needed for libnotify support"
- fi
- if use avahi; then
- eerror "The dbus USE flag is required for avahi support"
- die "USE=\"dbus\" needed for avahi support"
- fi
- fi
- python_pkg_setup
- python_set_active_version 2
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/window_class.patch
- ./autogen.sh || die "autogen.sh failed"
- echo '#!/bin/sh' > config/py-compile
-}
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_with X x) \
- --docdir="/usr/share/doc/${PF}" \
- --libdir="$(python_get_sitedir)" \
- --enable-site-packages
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- #rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
- dohtml README.html || die
-}
-
-pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/${PN}
-}