summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-12-31 12:24:54 -0500
committerRussell Harmon <russ@eatnumber1.com>2009-12-31 12:25:09 -0500
commit1c25b3f27780a2fc4eb014da2225171307871094 (patch)
tree976515b6ff56e5c49ab4879411b4f75549a0a6f1 /x11-misc
parentAdd keynav-20091231.01 ebuild. (diff)
downloadeatnumber1-1c25b3f27780a2fc4eb014da2225171307871094.tar.gz
eatnumber1-1c25b3f27780a2fc4eb014da2225171307871094.tar.bz2
eatnumber1-1c25b3f27780a2fc4eb014da2225171307871094.zip
Fix xdotool when compiling with --as-needed
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdotool/Manifest3
-rw-r--r--x11-misc/xdotool/files/xdotool-20091231.01_as-needed.patch25
-rw-r--r--x11-misc/xdotool/xdotool-20091231.01.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
index 53a33ee..b00ac31 100644
--- a/x11-misc/xdotool/Manifest
+++ b/x11-misc/xdotool/Manifest
@@ -1,3 +1,4 @@
+AUX xdotool-20091231.01_as-needed.patch 655 RMD160 71a6393f466fcafd78c5a794137bc4d164c9e79b SHA1 2943fb88f3770de9db73b026dcb0b442c2b8daf2 SHA256 bc0fe2ef8127a145d81a78d00d3c094e6331fad67fa36103f3b6b8a6c1380bc5
AUX xdotool-20091231.01_install-D.patch 1181 RMD160 0b969762447a88252737a990b40ecf8f2384e93b SHA1 d7b370c87a2496e6bfc2638269e58754b9729355 SHA256 d83f97b9f3bfb55ea841fbecdf1e5267978492d08d0fe207d41e53b52cd1ae91
-EBUILD xdotool-20091231.01.ebuild 1000 RMD160 5d8dcc88d3be3bb15b0d9e16fb011715cd2b6c76 SHA1 c5a9de7ba04407239485c96c4edaca28f7741e4c SHA256 ddc5c79df27d11c356e59abeb992f3839e367f2e840611983625c040543e12a9
+EBUILD xdotool-20091231.01.ebuild 1039 RMD160 d5fb9a3105798de8cec6c9acb5f3a6b656ce7c4e SHA1 d859b8b8b5bdb37ce5e2e91fe1b4598170cf1ff9 SHA256 157bc89bc9b24bec82e1431eddd5190a7419ae583e3d3ec3bf6061f485d02bdb
DIST xdotool-20091231.01.tar.gz 23913 RMD160 ac567df0b8a2b6bbb9cb9b87bbe8f735592c276d SHA1 6f0b2404b2fa477bfb28f1cf437250e0a54308b9 SHA256 d880ee63a9bbf59c6d1e269987729594fd85003ffa08cf92b7c26d8ce762e0c2
diff --git a/x11-misc/xdotool/files/xdotool-20091231.01_as-needed.patch b/x11-misc/xdotool/files/xdotool-20091231.01_as-needed.patch
new file mode 100644
index 0000000..4b23e54
--- /dev/null
+++ b/x11-misc/xdotool/files/xdotool-20091231.01_as-needed.patch
@@ -0,0 +1,25 @@
+From a1ab3272ba6d1b3b3ce6aa16ecf6b69f9c087dea Mon Sep 17 00:00:00 2001
+From: Russell Harmon <russ@eatnumber1.com>
+Date: Thu, 31 Dec 2009 12:22:59 -0500
+Subject: [PATCH] Fix building with --as-needed
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index e1d755f..6fb5c04 100644
+--- a/Makefile
++++ b/Makefile
+@@ -63,7 +63,7 @@ xdo.c: xdo.h
+ xdotool.c: xdo.h
+
+ libxdo.so: xdo.o
+- $(LD) $(LDFLAGS) -shared -soname=libxdo.so.$(MINOR) $< -o $@
++ $(LD) -shared -soname=libxdo.so.$(MINOR) $< -o $@ $(LDFLAGS)
+
+ xdotool: xdotool.o xdo.o
+ $(CC) $(CFLAGS) xdotool.o xdo.o $(LDFLAGS) -o $@
+--
+1.6.4.4
+
diff --git a/x11-misc/xdotool/xdotool-20091231.01.ebuild b/x11-misc/xdotool/xdotool-20091231.01.ebuild
index b7876aa..0f0c651 100644
--- a/x11-misc/xdotool/xdotool-20091231.01.ebuild
+++ b/x11-misc/xdotool/xdotool-20091231.01.ebuild
@@ -21,7 +21,8 @@ DEPEND="x11-libs/libXtst
RDEPEND="${DEPEND}"
src_prepare() {
- epatch "${FILESDIR}/${P}_install-D.patch"
+ epatch "${FILESDIR}/${P}_install-D.patch" \
+ "${FILESDIR}/${P}_as-needed.patch"
}
src_compile() {