summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/mozplugger/mozplugger-1.13.2.ebuild')
-rw-r--r--www-plugins/mozplugger/mozplugger-1.13.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-plugins/mozplugger/mozplugger-1.13.2.ebuild b/www-plugins/mozplugger/mozplugger-1.13.2.ebuild
new file mode 100644
index 0000000..d1aae74
--- /dev/null
+++ b/www-plugins/mozplugger/mozplugger-1.13.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozplugger/mozplugger-1.12.1.ebuild,v 1.1 2009/08/18 21:15:49 beandog Exp $
+
+inherit nsplugins
+
+DESCRIPTION="Streaming media plugin for Mozilla, based on netscape-plugger"
+SRC_URI="http://mozplugger.mozdev.org/files/${P}.tar.gz"
+HOMEPAGE="http://mozplugger.mozdev.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}
+ || ( net-libs/xulrunner
+ www-client/mozilla-firefox
+ www-client/seamonkey )"
+
+src_compile() {
+ emake linux || die
+}
+
+src_install() {
+ emake root="${D}" install || die "install failed"
+ src_mv_plugins /usr/lib/mozilla/plugins
+
+ dodoc ChangeLog README || die "dodoc failed"
+}