aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2019-07-19 07:59:10 +0200
committerNicholas Fish <gentoo@seaofdirac.net>2019-07-19 07:59:10 +0200
commit91a641694b9b28d33d8ac4cd35c75c8e75046847 (patch)
treeb68008d91f192cb6ff99c59284305dbe83d3a31f
parentgnome-base/dconf: Add trimming DBUS dependency (diff)
downloadennui-91a641694b9b28d33d8ac4cd35c75c8e75046847.tar.gz
ennui-91a641694b9b28d33d8ac4cd35c75c8e75046847.tar.bz2
ennui-91a641694b9b28d33d8ac4cd35c75c8e75046847.zip
app-admin/terraform: Add latest version
Signed-off-by: Nicholas Fish <gentoo@seaofdirac.net>
-rw-r--r--app-admin/terraform/Manifest3
-rw-r--r--app-admin/terraform/metadata.xml28
-rw-r--r--app-admin/terraform/terraform-0.12.5.ebuild39
3 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/terraform/Manifest b/app-admin/terraform/Manifest
new file mode 100644
index 0000000..33ac610
--- /dev/null
+++ b/app-admin/terraform/Manifest
@@ -0,0 +1,3 @@
+DIST terraform-0.12.5.tar.gz 9719080 BLAKE2B 938d254b53c1af259534380087edee16a8d4a1e65fed8b05d9f54e87a540d776278560a28a7021cd5d856ceba2556288210aeafc7b986a03a4a8ee88a7abf971 SHA512 8b559475aeb8689f0495febeb9c95fed1a2b00126dd3ef68fef2625dbf1c603b682849bad9c9e59dd6d16d347c9b6c1509c9745ceb95c6ab909ec4c4d121203e
+EBUILD terraform-0.12.5.ebuild 876 BLAKE2B 2d85cd105d8bfacde80d8ed86377b1393fb54ad8b3b8f17c88182af566f90afdbba2f71d8eb01f77aeebb0db5a58aca659197684724cd98b4ca6fbb05ad70a45 SHA512 9372702b9fe184e56ec8669c6fe228fa7306976c344f3174b19d1bb05136f8667f4dfadc1a2cdc568f9e6216301ddc06344b268b3a577e03bebd4386142bcef0
+MISC metadata.xml 1185 BLAKE2B 4e3e36b75d012f5a48886bc4cbce9f2f597b15060cf5298036690e3832e909ac6e08a729b477de9b893a38ea8cb634c8abefeb5776a14a790f5b4d8a7b86bc38 SHA512 8f52d688db4c37ddbdbca03c5a2f8fc49fa9a0765902e34559408f5f14230c12bc2b160768d3c9cbc978a0ee01e5f3c8a50aef00786a96f42725db54cb845d03
diff --git a/app-admin/terraform/metadata.xml b/app-admin/terraform/metadata.xml
new file mode 100644
index 0000000..6cdb29b
--- /dev/null
+++ b/app-admin/terraform/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dan@danmolik.com</email>
+ <name>Dan Molik</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Terraform is a tool for building, changing, and versioning infrastructure
+ safely and efficiently. Terraform can manage existing and popular service
+ providers as well as custom in-house solutions.
+
+ Terraform files describe the components needed to run a single application
+ or your entire datacenter. Terraform generates an execution plan describing
+ what it will do to reach the desired state, and then executes it to build
+ the described infrastructure. As the configuration changes, Terraform is
+ able to determine what changed and create incremental execution plans which
+ can be applied.
+ </longdescription>
+ <upstream>
+ <changelog>https://github.com/hashicorp/terraform/blob/master/CHANGELOG.md</changelog>
+ <remote-id type="github">hashicorp/terraform</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/terraform/terraform-0.12.5.ebuild b/app-admin/terraform/terraform-0.12.5.ebuild
new file mode 100644
index 0000000..9469446
--- /dev/null
+++ b/app-admin/terraform/terraform-0.12.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-lang/go-1.11.0"
+
+DOCS=( README.md CHANGELOG.md )
+
+src_compile() {
+ cd "src/${EGO_PN}" || die
+ GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
+ -v -work -o "${S}/${PN}" ./ || die
+}
+
+src_install() {
+ dobin terraform
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ einstalldocs
+ popd >/dev/null || die
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " terraform -install-autocomplete"
+}