aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/mako')
-rw-r--r--gui-apps/mako/Manifest4
-rw-r--r--gui-apps/mako/mako-1.4.ebuild50
-rw-r--r--gui-apps/mako/mako-9999.ebuild51
-rw-r--r--gui-apps/mako/metadata.xml19
4 files changed, 124 insertions, 0 deletions
diff --git a/gui-apps/mako/Manifest b/gui-apps/mako/Manifest
new file mode 100644
index 0000000..3e16ad5
--- /dev/null
+++ b/gui-apps/mako/Manifest
@@ -0,0 +1,4 @@
+DIST mako-1.4.tar.gz 48418 BLAKE2B ebd3c2f6fb7d51df826cab469c3e12477ec4503e3dfdfb4e9700393c0d994f6d7fcce6f3471d5faf90c5eb4bfa766941b97b0c8a8a556b5639ad5f3612df3082 SHA512 6059103e3a0c0cca5b0f717fbd7522f9a13f3dd3d65fe674e65cc175122a3372041bee2050d253ccb47a2adaa1dfa3180a19276bcdcb20c1e00813d75e1b3683
+EBUILD mako-1.4.ebuild 865 BLAKE2B dd8f33714d212871dc02e01f172d32c0ad021a39df24670c47447178bf408a0f74e50197012156b4234c78653b91396d3943a6152036b4c560f9ccb967530a44 SHA512 f33d155e766f65d4fbc7013d8b65bff703e738c173be02cb08a7877f245f07acb238a220e353e30e08d1ad5aaae81e0e3e378572ec1e619c03553fd275195381
+EBUILD mako-9999.ebuild 894 BLAKE2B 5d7a5aa5cbac293bc0b1f9e0e5bed07c38a2c2548da92a95c907f48c2ce310fd20f88e695bbd956be3044178a268198abcffb62c104b1ca075318528981baa50 SHA512 c30b91982ab4b20a31831a16df7807a14ad46fcfab6ad5f6b7a7ff6ca28b54188abc95dec2c08aac90bbd132a815b1ec88fd106d6a3a1d682938b645791524c0
+MISC metadata.xml 642 BLAKE2B 4b96d18b0cf351347a12d6e520d7aace4de2f7df8532953288dcfa2549cde936417b73499e0d0b7debd7716d1b49431db6529a213da0b69491df081400af8ae8 SHA512 51c3f7458f486883613916701f721045c3f7f82c9be1b8feb781632e38489e08c1d84411daaf56e01bc07d06c3b1c1683f55a79a51b4d6fd0f522ce97d303c8a
diff --git a/gui-apps/mako/mako-1.4.ebuild b/gui-apps/mako/mako-1.4.ebuild
new file mode 100644
index 0000000..6d7105b
--- /dev/null
+++ b/gui-apps/mako/mako-1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+icons"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/mako/mako-9999.ebuild b/gui-apps/mako/mako-9999.ebuild
new file mode 100644
index 0000000..60eca46
--- /dev/null
+++ b/gui-apps/mako/mako-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+icons"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/mako/metadata.xml b/gui-apps/mako/metadata.xml
new file mode 100644
index 0000000..f4af030
--- /dev/null
+++ b/gui-apps/mako/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A lightweight notification daemon for Wayland. Works on Sway.
+ </longdescription>
+ <use>
+ <flag name="icons">Enable support for icons</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emmersion/mako</remote-id>
+ <bugs-to>https://github.com/emersion/mako/issues</bugs-to>
+ <changelog>https://github.com/emersion/mako/releases</changelog>
+ </upstream>
+</pkgmetadata>