summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHoang Minh Thang <hoangminhthang@ktqd.org>2012-02-24 13:35:19 +0700
committerHoang Minh Thang <hoangminhthang@ktqd.org>2012-02-24 13:35:19 +0700
commitf1be648d383d345dc9731fa57da8ef42d3b16858 (patch)
treee57f5565026584172ef54139636f65556496020d /app-accessibility/espeak
parentposterazor (diff)
downloadgentoo-vn-f1be648d383d345dc9731fa57da8ef42d3b16858.tar.gz
gentoo-vn-f1be648d383d345dc9731fa57da8ef42d3b16858.tar.bz2
gentoo-vn-f1be648d383d345dc9731fa57da8ef42d3b16858.zip
update b2u, do some cleanup
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/espeak-1.42.04.ebuild79
-rw-r--r--app-accessibility/espeak/espeak-1.45.03.ebuild72
-rw-r--r--app-accessibility/espeak/espeak-1.45.04.ebuild72
3 files changed, 0 insertions, 223 deletions
diff --git a/app-accessibility/espeak/espeak-1.42.04.ebuild b/app-accessibility/espeak/espeak-1.42.04.ebuild
deleted file mode 100644
index 33f16bc..0000000
--- a/app-accessibility/espeak/espeak-1.42.04.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.42.04.ebuild,v 1.8 2010/07/20 18:37:03 jer Exp $
-
-EAPI="2"
-
-inherit eutils
-
-MY_P="${P}-source"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-DESCRIPTION="Speech synthesizer for English and other languages"
-HOMEPAGE="http://espeak.sourceforge.net/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="portaudio pulseaudio"
-RDEPEND="portaudio? ( >=media-libs/portaudio-19_pre20071207 )
- pulseaudio? ( media-sound/pulseaudio )"
- DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-get_audio() {
- local MY_AUDIO
-
- if use portaudio; then
- MY_AUDIO=portaudio
- elif use pulseaudio; then
- MY_AUDIO=pulseaudio
- else
- MY_AUDIO=none
- fi
- echo ${MY_AUDIO}
-}
-
-pkg_setup() {
- if ! use portaudio && ! use pulseaudio; then
- ewarn
- ewarn Since portaudio and pulseaudio are not in your use flags,
- ewarn espeak will only be able to create wav files.
- ewarn If this is not what you want, press ctrl-c and put either
- ewarn portaudio or pulseaudio in your use flags.
- ebeep
- epause 10
- elif use portaudio && use pulseaudio; then
- die "You must choose either portaudio or pulseaudio, but not both."
- fi
-}
-
-src_prepare() {
- cd src
- # gentoo uses portaudio 19.
- if use portaudio; then
- mv -f portaudio19.h portaudio.h
- fi
-}
-
-src_compile() {
- cd src
- emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
-
- einfo "Fixing byte order of phoneme data files"
- cd "${S}/platforms/big_endian"
- make
- ./espeak-phoneme-data "${S}/espeak-data"
- cp -f phondata phonindex phontab "${S}/espeak-data"
-}
-
-src_install() {
- cd src
- make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
-
- cd ..
- insinto /usr/share/espeak-data
- doins -r dictsource
- dodoc ChangeLog ReadMe
- dohtml -r docs/*
-}
diff --git a/app-accessibility/espeak/espeak-1.45.03.ebuild b/app-accessibility/espeak/espeak-1.45.03.ebuild
deleted file mode 100644
index e3674db..0000000
--- a/app-accessibility/espeak/espeak-1.45.03.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.45.03.ebuild,v 1.1 2011/03/22 17:10:56 williamh Exp $
-
-EAPI="4"
-
-inherit eutils toolchain-funcs
-
-MY_P="${P}-source"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-DESCRIPTION="Speech synthesizer for English and other languages"
-HOMEPAGE="http://espeak.sourceforge.net/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="portaudio pulseaudio"
-REQUIRED_USE="portaudio? ( !pulseaudio )
- pulseaudio? ( !portaudio )"
- RDEPEND=" pulseaudio? ( media-sound/pulseaudio )
- portaudio? ( >=media-libs/portaudio-19_pre20071207 )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-get_audio() {
- if use portaudio; then
- echo portaudio
- elif use pulseaudio; then
- echo pulseaudio
- else
- echo none
- fi
-}
-
-src_prepare() {
- cd src
- # gentoo uses portaudio 19.
- mv -f portaudio19.h portaudio.h
-}
-
-src_compile() {
- cd src
- emake PREFIX="${EPREFIX}/usr" AUDIO="$(get_audio)" \
- CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" all
-
- einfo "Fixing byte order of phoneme data files"
- cd "${S}/platforms/big_endian"
- make
- ./espeak-phoneme-data "${S}/espeak-data"
- cp -f phondata phonindex phontab "${S}/espeak-data"
-}
-
-src_install() {
- cd src
- make DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="\$(PREFIX)/$(get_libdir)" AUDIO="$(get_audio)" install
-
- cd ..
- insinto /usr/share/espeak-data
- doins -r dictsource
- dodoc ChangeLog.txt ReadMe
- dohtml -r docs/*
-}
-
-pkg_postinst() {
- if ! use portaudio && ! use pulseaudio; then
- ewarn "Since portaudio and pulseaudio are not in your use flags,"
- ewarn "espeak will only be able to create wav files."
- ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
- ewarn "with either portaudio or pulseaudio USE flag enabled."
- fi
-}
diff --git a/app-accessibility/espeak/espeak-1.45.04.ebuild b/app-accessibility/espeak/espeak-1.45.04.ebuild
deleted file mode 100644
index 2a1f4f0..0000000
--- a/app-accessibility/espeak/espeak-1.45.04.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.45.04.ebuild,v 1.5 2011/12/04 16:06:46 armin76 Exp $
-
-EAPI="4"
-
-inherit eutils toolchain-funcs
-
-MY_P="${P}-source"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-DESCRIPTION="Speech synthesizer for English and other languages"
-HOMEPAGE="http://espeak.sourceforge.net/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="portaudio pulseaudio"
-REQUIRED_USE="portaudio? ( !pulseaudio )
- pulseaudio? ( !portaudio )"
- RDEPEND=" pulseaudio? ( media-sound/pulseaudio )
- portaudio? ( >=media-libs/portaudio-19_pre20071207 )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-get_audio() {
- if use portaudio; then
- echo portaudio
- elif use pulseaudio; then
- echo pulseaudio
- else
- echo none
- fi
-}
-
-src_prepare() {
- cd src
- # gentoo uses portaudio 19.
- mv -f portaudio19.h portaudio.h
-}
-
-src_compile() {
- cd src
- emake PREFIX="${EPREFIX}/usr" AUDIO="$(get_audio)" \
- CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" all
-
- einfo "Fixing byte order of phoneme data files"
- cd "${S}/platforms/big_endian"
- make
- ./espeak-phoneme-data "${S}/espeak-data"
- cp -f phondata phonindex phontab "${S}/espeak-data"
-}
-
-src_install() {
- cd src
- make DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="\$(PREFIX)/$(get_libdir)" AUDIO="$(get_audio)" install
-
- cd ..
- insinto /usr/share/espeak-data
- doins -r dictsource
- dodoc ChangeLog.txt ReadMe
- dohtml -r docs/*
-}
-
-pkg_postinst() {
- if ! use portaudio && ! use pulseaudio; then
- ewarn "Since portaudio and pulseaudio are not in your use flags,"
- ewarn "espeak will only be able to create wav files."
- ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
- ewarn "with either portaudio or pulseaudio USE flag enabled."
- fi
-}