summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHoang Minh Thang <hoangminhthang@ktqd.org>2012-07-26 23:06:37 +0700
committerHoang Minh Thang <hoangminhthang@ktqd.org>2012-07-26 23:06:37 +0700
commit60aeaaedaf4531cc1b27bd0d62c36466a265cfed (patch)
tree8e0b5f2f256632489f2ae352f71389712fc0381a /app-text/cherrytree
parentadd ekho (diff)
downloadgentoo-vn-master.tar.gz
gentoo-vn-master.tar.bz2
gentoo-vn-master.zip
add cherrytreeHEADmaster
Diffstat (limited to 'app-text/cherrytree')
-rw-r--r--app-text/cherrytree/Manifest4
-rw-r--r--app-text/cherrytree/cherrytree-0.25.4.ebuild41
-rw-r--r--app-text/cherrytree/cherrytree-0.26.3.ebuild41
3 files changed, 86 insertions, 0 deletions
diff --git a/app-text/cherrytree/Manifest b/app-text/cherrytree/Manifest
new file mode 100644
index 0000000..f875f8a
--- /dev/null
+++ b/app-text/cherrytree/Manifest
@@ -0,0 +1,4 @@
+DIST cherrytree-0.25.4.tar.gz 1095686 RMD160 d71ec02d2c72c4e94d6b57a06b1714366e778982 SHA1 bd87be5631a084587548f8d096245eb99edaf3b4 SHA256 72c9b1746aa2126864f600cc9206a699c8aa184e23e7f593bd066cb3198feda8
+DIST cherrytree-0.26.3.tar.bz2 803389 RMD160 159087aeaed8c864cd79311fa6cb3250b75999cc SHA1 3e4a4f2b473a8523652485f98171ec5418ffa271 SHA256 4c079fe17dab20b5d999c1cc66c8ca21ceba14c177e7a16bd308826835c2b2fb
+EBUILD cherrytree-0.25.4.ebuild 1033 RMD160 6262c0bc907ccbf60eb692fd590630f5e8e62503 SHA1 e02f7eea2f5af19627e34d569517889d3d606e6a SHA256 0d07301640d0014532eed3041912bf505f5dee0ae28096bfd146e449b7960685
+EBUILD cherrytree-0.26.3.ebuild 1034 RMD160 e7b52fda7829dedf54650093b803bdde4b103bb0 SHA1 82e417688ae357af34db7a99e0f3f56202baeeb4 SHA256 31462228c5bf538149e3e80b7926f39934db040aaf6764628fcf3f9e0b7602d4
diff --git a/app-text/cherrytree/cherrytree-0.25.4.ebuild b/app-text/cherrytree/cherrytree-0.25.4.ebuild
new file mode 100644
index 0000000..0f8de39
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.25.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cherrytree/cherrytree-0.25.ebuild,v 1.1 2011/06/09 07:41:52 radhermit Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython"
+
+inherit distutils eutils fdo-mime
+
+DESCRIPTION="A hierarchical note taking application"
+HOMEPAGE="http://www.giuspen.com/cherrytree/"
+SRC_URI="http://www.giuspen.com/software/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=dev-python/pygtk-2.12:2
+ dev-python/pygtksourceview"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ "
+
+src_prepare() {
+ # Avoid sandbox violation
+ sed -e "s:subprocess.call(\"update-desktop-database\"):#subprocess.call(\"update-desktop-database\"):g" \
+ -i setup.py || die "sed failed to patch install.py"
+
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
diff --git a/app-text/cherrytree/cherrytree-0.26.3.ebuild b/app-text/cherrytree/cherrytree-0.26.3.ebuild
new file mode 100644
index 0000000..6b9875b
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.26.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cherrytree/cherrytree-0.25.ebuild,v 1.1 2011/06/09 07:41:52 radhermit Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython"
+
+inherit distutils eutils fdo-mime
+
+DESCRIPTION="A hierarchical note taking application"
+HOMEPAGE="http://www.giuspen.com/cherrytree/"
+SRC_URI="http://www.giuspen.com/software/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=dev-python/pygtk-2.12:2
+ dev-python/pygtksourceview"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ "
+
+src_prepare() {
+ # Avoid sandbox violation
+ sed -e "s:subprocess.call(\"update-desktop-database\"):#subprocess.call(\"update-desktop-database\"):g" \
+ -i setup.py || die "sed failed to patch install.py"
+
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+