aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-07-03 14:29:30 -0700
committerGregory M. Tuner <gmt@be-evil.net>2014-07-03 14:29:30 -0700
commit2a970b5f72ae0316ae20597b58b0dcb1198319da (patch)
tree54c154b4affff979e29069f2f6d01716ee842127 /net-libs/libsoup-gnome/libsoup-gnome-2.46.0-r1.ebuild
parentapp-portage/overlay-upstream-tracking: change git provider yet again: this ti... (diff)
downloadgmt-2a970b5f72ae0316ae20597b58b0dcb1198319da.tar.gz
gmt-2a970b5f72ae0316ae20597b58b0dcb1198319da.tar.bz2
gmt-2a970b5f72ae0316ae20597b58b0dcb1198319da.zip
net-libs/libsoup-gnome: version-bump: 2.46.0-r1
Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'net-libs/libsoup-gnome/libsoup-gnome-2.46.0-r1.ebuild')
-rw-r--r--net-libs/libsoup-gnome/libsoup-gnome-2.46.0-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/libsoup-gnome/libsoup-gnome-2.46.0-r1.ebuild b/net-libs/libsoup-gnome/libsoup-gnome-2.46.0-r1.ebuild
new file mode 100644
index 0000000..9631556
--- /dev/null
+++ b/net-libs/libsoup-gnome/libsoup-gnome-2.46.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+MY_PN=${PN/-gnome}
+MY_P=${MY_PN}-${PV}
+
+inherit gnome2-multilib autotools eutils
+
+DESCRIPTION="GNOME plugin for libsoup"
+HOMEPAGE="https://wiki.gnome.org/LibSoup"
+SRC_URI="${SRC_URI//-gnome}"
+
+LICENSE="LGPL-2+"
+SLOT="2.4"
+IUSE="debug +introspection"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ ~net-libs/libsoup-${PV}[introspection?,${MULTILIB_USEDEP}]
+ >=dev-db/sqlite-3.8.3:3=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5[${MULTILIB_USEDEP}] )
+ >=net-libs/libsoup-2.42.2-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.18.3.2[${MULTILIB_USEDEP}]
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Use lib present on the system
+ epatch "${FILESDIR}"/${PN}-2.46.0-system-lib.patch
+ AUTOTOOLS_AUTORECONF=yes gnome2-multilib_src_prepare
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ gnome2-multilib_src_configure \
+ --disable-static \
+ --disable-tls-check \
+ $(use_enable introspection) \
+ --with-libsoup-system \
+ --with-gnome \
+ --without-apache-httpd
+}