aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-01-22 20:02:55 -0800
committerGregory M. Tuner <gmt@be-evil.net>2014-01-22 20:02:55 -0800
commit08fce7f1ddc312fb8fd97965c5289dbdc12afd05 (patch)
treeee83667be1a8e85e87c576b30581c9892a11f168 /x11-libs/libview/libview-0.6.6-r3.ebuild
parentx11-libs/pangox-compat: clone upstream (diff)
downloadgmt-08fce7f1ddc312fb8fd97965c5289dbdc12afd05.tar.gz
gmt-08fce7f1ddc312fb8fd97965c5289dbdc12afd05.tar.bz2
gmt-08fce7f1ddc312fb8fd97965c5289dbdc12afd05.zip
x11-libs/libview: clone upstream
Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'x11-libs/libview/libview-0.6.6-r3.ebuild')
-rw-r--r--x11-libs/libview/libview-0.6.6-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-libs/libview/libview-0.6.6-r3.ebuild b/x11-libs/libview/libview-0.6.6-r3.ebuild
new file mode 100644
index 0000000..0a68317
--- /dev/null
+++ b/x11-libs/libview/libview-0.6.6-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="VMware's Incredibly Exciting Widgets"
+HOMEPAGE="http://view.sourceforge.net"
+SRC_URI="mirror://sourceforge/view/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND=">=x11-libs/gtk+-2.4.0:2
+ dev-cpp/gtkmm:2.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+G2CONF="--enable-deprecated"
+
+src_unpack() {
+ gnome2_src_unpack
+}
+
+src_prepare() {
+ # Fix the pkgconfig file
+ epatch "${FILESDIR}"/${PN}-0.5.6-pcfix.patch
+ eautoreconf -i
+}
+src_configure() {
+ econf \
+ --enable-deprecated \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS
+
+ find "${ED}" -name '*.la' -delete
+}