summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Köster <koesterreich@fastmail.fm>2012-10-27 10:43:08 +0200
committerFabian Köster <koesterreich@fastmail.fm>2012-10-27 10:43:08 +0200
commitdd83a8774c3ff6d488e78dc450c4a323fb4bb776 (patch)
tree0fa62a20c45e957bf21874f6f9b4af419eba2936 /net-libs/hbci4java/files
downloadhibiscus-dd83a8774c3ff6d488e78dc450c4a323fb4bb776.tar.gz
hibiscus-dd83a8774c3ff6d488e78dc450c4a323fb4bb776.tar.bz2
hibiscus-dd83a8774c3ff6d488e78dc450c4a323fb4bb776.zip
Initial commit
Diffstat (limited to 'net-libs/hbci4java/files')
-rw-r--r--net-libs/hbci4java/files/2.5.12-build.patch60
-rw-r--r--net-libs/hbci4java/files/2.5.12-makefile.patch139
2 files changed, 199 insertions, 0 deletions
diff --git a/net-libs/hbci4java/files/2.5.12-build.patch b/net-libs/hbci4java/files/2.5.12-build.patch
new file mode 100644
index 0000000..73f1c8d
--- /dev/null
+++ b/net-libs/hbci4java/files/2.5.12-build.patch
@@ -0,0 +1,60 @@
+Index: hbci4java-2.5.12-src/build.xml
+===================================================================
+--- hbci4java-2.5.12-src.orig/build.xml
++++ hbci4java-2.5.12-src/build.xml
+@@ -14,7 +14,11 @@
+ </path>
+
+ <target name="compile"
+- description="compile all the needed stuff; after that add dir 'classes' to the classpath; in dir 'chipcard/lib' you will find the ddv-library needed for accessing your chipcard terminal">
++ description="compile all the needed stuff; after that add dir 'classes' to the classpath; in dir 'chipcard/lib' you will find the ddv-library needed for accessing your chipcard terminal"
++ depends="compile-java, compile-chipcard" />
++
++ <target name="compile-java"
++ description="Compile the Java library">
+ <mkdir dir="${classes}"/>
+ <javac srcdir="${src}" destdir="${classes}"
+ debug="on" encoding="ISO-8859-1"
+@@ -39,17 +43,20 @@
+ </fileset>
+ <mapper type="glob" from="messages*" to="HBCIMessages*" />
+ </copy>
++ </target>
+
+- <javah class="org.kapott.hbci.passport.HBCIPassportDDV"
+- outputFile="${chipcard}/src/include/frontend.h"
++ <target name="compile-chipcard" depends="compile-java"
++ description="Compiles the driver for chipcard terminals">
++ <javah class="org.kapott.hbci.passport.HBCIPassportDDV"
++ outputFile="${chipcard}/src/include/frontend.h"
+ classpath="${classes}"/>
+-
++
+ <exec executable="${make}" os="Linux">
+ <arg line="-C ${chipcard}"/>
+ </exec>
+ </target>
+
+- <target name="package" depends="compile">
++ <target name="package" depends="compile-java">
+ <mkdir dir="${dist}/jar"/>
+ <jar destfile="${dist}/jar/hbci4java.jar"
+ basedir="${classes}" compress="true">
+@@ -96,7 +103,7 @@
+ <include name="tools/HBCIBatch.java"/>
+ </fileset>
+
+- <target name="javadoc" depends="compile"
++ <target name="javadoc" depends="compile-java"
+ description="create javadoc documentation">
+ <mkdir dir="${doc}/javadoc" />
+ <javadoc classpath="${classes}"
+@@ -111,7 +118,7 @@
+ </javadoc>
+ </target>
+
+- <target name="dist" depends="package,javadoc"
++ <target name="dist" depends="compile,package,javadoc"
+ description="bundle all required stuff in a single directory (dir 'dist').">
+
+ <mkdir dir="${dist}/templates"/>
diff --git a/net-libs/hbci4java/files/2.5.12-makefile.patch b/net-libs/hbci4java/files/2.5.12-makefile.patch
new file mode 100644
index 0000000..f679274
--- /dev/null
+++ b/net-libs/hbci4java/files/2.5.12-makefile.patch
@@ -0,0 +1,139 @@
+Index: hbci4java-2.5.12-src/chipcard/src/frontend/Makefile
+===================================================================
+--- hbci4java-2.5.12-src.orig/chipcard/src/frontend/Makefile
++++ hbci4java-2.5.12-src/chipcard/src/frontend/Makefile
+@@ -4,8 +4,9 @@ INCLUDES = -I../include -I$(JAVA_HOME)/i
+ WARNINGS = -Wall
+ # removed "-Werror -pedantic" because of dlsym() typecast problem
+
+-CC = g++
+-CFLAGS = -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
++CXX ?= g++
++AR ?= ar
++CXXFLAGS += -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
+ LIBS = -L../../bin -lzkachip-highlevel -lzkachip-lowlevel
+
+ SOURCES = frontend.cpp
+@@ -15,16 +16,16 @@ OBJECTS = ../../bin/frontend.o
+ .SUFFIXES: .cpp .o
+
+ ../../bin/%.o: %.cpp
+- $(CC) -c -o $@ $(CFLAGS) $<
++ $(CXX) -c -o $@ $(CXXFLAGS) $(LDFLAGS) $<
+
+ all: depend ../../bin/libhbci4java-card-linux.so
+
+ depend: Makefile.depend
+
+ Makefile.depend: $(SOURCES)
+- for file in $(SOURCES); do echo -n "../../bin/"; gcc $(CFLAGS) -MM $$file; done >Makefile.depend
++ for file in $(SOURCES); do echo -n "../../bin/"; $(CXX) $(CXXFLAGS) $(LDFLAGS) -MM $$file; done >Makefile.depend
+
+ ../../bin/libhbci4java-card-linux.so: $(OBJECTS) ../../bin/libzkachip-highlevel.a ../../bin/libzkachip-lowlevel.a
+- $(CC) -fPIC -shared -o $@ $(OBJECTS) $(LIBS)
++ $(CXX) $(LDFLAGS) -fPIC -shared -o $@ $(OBJECTS) $(LIBS)
+
+ include Makefile.depend
+Index: hbci4java-2.5.12-src/chipcard/src/highlevel/Makefile
+===================================================================
+--- hbci4java-2.5.12-src.orig/chipcard/src/highlevel/Makefile
++++ hbci4java-2.5.12-src/chipcard/src/highlevel/Makefile
+@@ -4,9 +4,9 @@ INCLUDES = -I../include
+ WARNINGS = -Wall
+ # removed "-Werror -pedantic" because of dlsym() typecast problem
+
+-CC = g++
+-AR = ar
+-CFLAGS = -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
++CXX ?= g++
++AR ?= ar
++CXXFLAGS += -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
+
+ SOURCES = hbci_cardtype.cpp \
+ ddv_decrypt.cpp \
+@@ -37,14 +37,14 @@ OBJECTS = ../../bin/hbci_cardtype.o \
+ .SUFFIXES: .cpp .o
+
+ ../../bin/%.o: %.cpp
+- $(CC) -c -o $@ $(CFLAGS) $<
++ $(CXX) -c -o $@ $(CXXFLAGS) $(LDFLAGS) $<
+
+ all: depend ../../bin/libzkachip-highlevel.a
+
+ depend: Makefile.depend
+
+ Makefile.depend: $(SOURCES)
+- for file in $(SOURCES); do echo -n "../../bin/"; gcc $(CFLAGS) -MM $$file; done >Makefile.depend
++ for file in $(SOURCES); do echo -n "../../bin/"; $(CXX) $(CXXFLAGS) $(LDFLAGS) -MM $$file; done >Makefile.depend
+
+ ../../bin/libzkachip-highlevel.a: $(OBJECTS)
+ $(AR) rcsv $@ $(OBJECTS)
+Index: hbci4java-2.5.12-src/chipcard/src/lowlevel/Makefile
+===================================================================
+--- hbci4java-2.5.12-src.orig/chipcard/src/lowlevel/Makefile
++++ hbci4java-2.5.12-src/chipcard/src/lowlevel/Makefile
+@@ -4,9 +4,9 @@ INCLUDES = -I../include
+ WARNINGS = -Wall
+ # removed "-Werror -pedantic" because of dlsym() typecast problem
+
+-CC = g++
+-AR = ar
+-CFLAGS = -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
++CXX ?= g++
++AR ?= ar
++CXXFLAGS += -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
+
+ SOURCES = atr.cpp \
+ bcs.cpp \
+@@ -41,14 +41,14 @@ OBJECTS = ../../bin/atr.o \
+ .SUFFIXES: .cpp .o
+
+ ../../bin/%.o: %.cpp
+- $(CC) -c -o $@ $(CFLAGS) $<
++ $(CXX) -c -o $@ $(CXXFLAGS) $(LDFLAGS) $<
+
+ all: depend ../../bin/libzkachip-lowlevel.a
+
+ depend: Makefile.depend
+
+ Makefile.depend: $(SOURCES)
+- for file in $(SOURCES); do echo -n "../../bin/"; gcc $(CFLAGS) -MM $$file; done >Makefile.depend
++ for file in $(SOURCES); do echo -n "../../bin/"; $(CXX) $(CXXFLAGS) $(LDFLAGS) -MM $$file; done >Makefile.depend
+
+ ../../bin/libzkachip-lowlevel.a: $(OBJECTS)
+ $(AR) rcsv $@ $(OBJECTS)
+Index: hbci4java-2.5.12-src/chipcard/src/tools/Makefile
+===================================================================
+--- hbci4java-2.5.12-src.orig/chipcard/src/tools/Makefile
++++ hbci4java-2.5.12-src/chipcard/src/tools/Makefile
+@@ -4,8 +4,9 @@ INCLUDES = -I../include
+ WARNINGS = -Wall
+ # removed "-Werror -pedantic" because of dlsym() typecast problem
+
+-CC = g++
+-CFLAGS = -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
++CXX ?= g++
++AR ?= ar
++CXXFLAGS += -fPIC $(DEFINES) $(INCLUDES) $(WARNINGS)
+ LIBS = -L../../bin -lzkachip-highlevel -lzkachip-lowlevel -ldl
+
+ SOURCES = t_hbci_cardinfo.cpp \
+@@ -29,15 +30,15 @@ PROGRAMS = ../../bin/t_hbci_cardinfo \
+ .SUFFIXES: .cpp .o
+
+ ../../bin/%.o: %.cpp
+- $(CC) -c -o $@ $(CFLAGS) $<
++ $(CXX) -c -o $@ $(CXXFLAGS) $(LDFLAGS) $<
+ ../../bin/%: ../../bin/%.o ../../bin/libzkachip-highlevel.a ../../bin/libzkachip-lowlevel.a
+- $(CC) -fPIC -o $@ $< $(LIBS)
++ $(CXX) -fPIC -o $@ $< $(LIBS)
+
+ all: depend $(PROGRAMS)
+
+ depend: Makefile.depend
+
+ Makefile.depend: $(SOURCES)
+- for file in $(SOURCES); do echo -n "../../bin/"; gcc $(CFLAGS) -MM $$file; done >Makefile.depend
++ for file in $(SOURCES); do echo -n "../../bin/"; $(CXX) $(CXXFLAGS) $(LDFLAGS) -MM $$file; done >Makefile.depend
+
+ include Makefile.depend