aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2014-08-29 15:11:32 +0800
committerIan Delaney <della5@iinet.com.au>2014-08-29 15:11:32 +0800
commit69d5fc40f4278b1df447845e9392e23151095ba1 (patch)
treee33d6f48e73800f3d3fa191081347529d6b83b2f /dev-python/characteristic/characteristic-14.1.0.ebuild
parentmass purge of old ebuilds mostly in portage (diff)
downloadimprovise-69d5fc40f4278b1df447845e9392e23151095ba1.tar.gz
improvise-69d5fc40f4278b1df447845e9392e23151095ba1.tar.bz2
improvise-69d5fc40f4278b1df447845e9392e23151095ba1.zip
note for websocket-client in a diff file, add working service_identity, characteristic and some others
Diffstat (limited to 'dev-python/characteristic/characteristic-14.1.0.ebuild')
-rw-r--r--dev-python/characteristic/characteristic-14.1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/characteristic/characteristic-14.1.0.ebuild b/dev-python/characteristic/characteristic-14.1.0.ebuild
new file mode 100644
index 0000000..40de764
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test -a "--cov characteristic --cov-report term-missing"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}