aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-19 22:36:06 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-19 22:36:06 +0800
commit8a320d3e7a320de5eac520e1a2d134afca925da6 (patch)
tree8e00d2a292d6470f1164a1fed0ad7b650a7a5d2b /dev-python/django-evolution/django-evolution-0.6.7.ebuild
parent[dev-python/django-auth-ldap] final cleanup, Rm comment (diff)
downloadimprovise-8a320d3e7a320de5eac520e1a2d134afca925da6.tar.gz
improvise-8a320d3e7a320de5eac520e1a2d134afca925da6.tar.bz2
improvise-8a320d3e7a320de5eac520e1a2d134afca925da6.zip
[dev-python/[django-[auth-ldap,auth-ldap]] Removed, in portage. django-evolution final test phase revision
Diffstat (limited to 'dev-python/django-evolution/django-evolution-0.6.7.ebuild')
-rw-r--r--dev-python/django-evolution/django-evolution-0.6.7.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/django-evolution/django-evolution-0.6.7.ebuild b/dev-python/django-evolution/django-evolution-0.6.7.ebuild
index a1dbc4b..ba5f962 100644
--- a/dev-python/django-evolution/django-evolution-0.6.7.ebuild
+++ b/dev-python/django-evolution/django-evolution-0.6.7.ebuild
@@ -28,8 +28,12 @@ DEPEND="${RDEPEND}
dev-python/django"
src_test() {
+ # pypy registers 2 fails but does not return non zeros status and carries on!!!
testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib/)" "$(PYTHON)" tests/runtests.py
+ local exit_status=0
+ "$(PYTHON)" tests/runtests.py || exit_status=1
+ einfo "the status is $exit_status"
+ return $exit_status
}
python_execute_function testing
}
@@ -41,6 +45,6 @@ src_install() {
rmtests() {
rm -rf ${ED}/$(python_get_sitedir)/tests/ || die
}
- python_execute_function --action-message "${msg}" rmtests
+ python_execute_function --action-message "$msg" rmtests
dodoc docs/*
}