aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2014-11-12 08:19:47 +0800
committerIan Delaney <della5@iinet.com.au>2014-11-12 08:19:47 +0800
commitb24237bedabd813dce7e2ad74695788609aa783e (patch)
treefaab34d14fadc34588ad6b83798efc0c5cebaf54 /dev-python/flask-cors/flask-cors-1.6.1.ebuild
parentnote for websocket-client in a diff file, add working service_identity, chara... (diff)
downloadimprovise-b24237bedabd813dce7e2ad74695788609aa783e.tar.gz
improvise-b24237bedabd813dce7e2ad74695788609aa783e.tar.bz2
improvise-b24237bedabd813dce7e2ad74695788609aa783e.zip
radical update
Package-Manager: portage-2.2.14
Diffstat (limited to 'dev-python/flask-cors/flask-cors-1.6.1.ebuild')
-rw-r--r--dev-python/flask-cors/flask-cors-1.6.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/flask-cors/flask-cors-1.6.1.ebuild b/dev-python/flask-cors/flask-cors-1.6.1.ebuild
deleted file mode 100644
index a1a2b38..0000000
--- a/dev-python/flask-cors/flask-cors-1.6.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Cors"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Flask extension adding a decorator for CORS support"
-HOMEPAGE="https://github.com/wcdolphin/flask-cors https://pypi.python.org/pypi/Flask-Cors"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}