aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2013-07-18 19:17:28 +0800
committerIan Delaney <della5@iinet.com.au>2013-07-18 19:17:28 +0800
commit5fc0abab400f53060ff3c3feb0a8d369ff234288 (patch)
tree53f1b740666cafbbf2d053afecb1a892aff6badf /dev-python/kombu/kombu-2.5.10.ebuild
parent[dev-python/kombu] total overhaul of doc build, reset to _compile_all, tweak ... (diff)
downloadimprovise-5fc0abab400f53060ff3c3feb0a8d369ff234288.tar.gz
improvise-5fc0abab400f53060ff3c3feb0a8d369ff234288.tar.bz2
improvise-5fc0abab400f53060ff3c3feb0a8d369ff234288.zip
Remove old packages
Package-Manager: portage-2.1.11.63
Diffstat (limited to 'dev-python/kombu/kombu-2.5.10.ebuild')
-rw-r--r--dev-python/kombu/kombu-2.5.10.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/kombu/kombu-2.5.10.ebuild b/dev-python/kombu/kombu-2.5.10.ebuild
deleted file mode 100644
index 3b72167..0000000
--- a/dev-python/kombu/kombu-2.5.10.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_1,3_2} pypy{1_9,2_0} )
-
-inherit distutils-r1
-
-DESCRIPTION="AMQP Messaging Framework for Python"
-HOMEPAGE="http://pypi.python.org/pypi/kombu https://github.com/celery/kombu"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="amqplib doc examples test"
-
-RDEPEND=">=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
- amqplib? ( >=dev-python/amqplib-1.0.2[${PYTHON_USEDEP}] )
- >=dev-python/py-amqp-1.0.6[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose-cover3[${PYTHON_USEDEP}]
- >=dev-python/mock-0.7[${PYTHON_USEDEP}]
- dev-python/django[$(python_gen_usedep python{2_7,3_2})]
- >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/pymongo[$(python_gen_usedep 'python2_7' 'pypy{1_9,2_0}')]
- dev-python/msgpack[$(python_gen_usedep python{2_7,3_1,3_2})] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/django[$(python_gen_usedep python{2_7,3_2})]
- dev-python/beanstalkc[$(python_gen_usedep python2_7)]
- dev-python/couchdb-python[$(python_gen_usedep python2_7)] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- emake -C docs html || die "kombu docs failed installation"
- fi
-}
-
-# wip; https://github.com/celery/kombu/issues/227; at this point upstr. maintainer established these tests
-# 'can and do' pass, acks their failing 'on Travis' and offers neither a solution nor any plan to make 1.
-python_test() {
- if [[ "${EPYTHON}" == python3* ]]; then
- if [[ "${EPYTHON}" == 'python3.1' ]]; then
- einfo "python3.1 ill-equipped to run testsuite, skipped"
- else
- nosetests --py3where=build/lib -e 'test_basic_consume_registers_ack_status*' \
- -e 'test_close_resolves_connection_cycle*' -e 'test_init*' \
- -e 'test_message_to_python*' -e 'test_prepare_message*' \
- -e 'test_produce_consume*' -e 'test_produce_consume_noack*' kombu/tests \
- || die "Tests failed under ${EPYTHON}"
- fi
- else
- nosetests -e 'test_basic_consume_registers_ack_status*' -e 'test_close_resolves_connection_cycle*' \
- -e 'test_init*' -e 'test_message_to_python*' -e 'test_prepare_message*' \
- || die "Tests failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docompress -x usr/share/doc/${P}/examples/
- insinto usr/share/doc/${PF}/
- doins -r examples/
- fi
-
- use doc && dohtml -r ./docs/.build/html/
-}