aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2014-01-14 23:28:24 +0800
committerIan Delaney <della5@iinet.com.au>2014-01-14 23:28:24 +0800
commit93cfbdb2b9cec2a6c9ed93882d1076300f5688e9 (patch)
treedc6dc17245ec0423784e18d255da83f83ccfbc5a /dev-python/pbr/pbr-0.5.21.ebuild
parentRemove double quotes in HOMEPAGE (diff)
downloadimprovise-93cfbdb2b9cec2a6c9ed93882d1076300f5688e9.tar.gz
improvise-93cfbdb2b9cec2a6c9ed93882d1076300f5688e9.tar.bz2
improvise-93cfbdb2b9cec2a6c9ed93882d1076300f5688e9.zip
long overdue update
Package-Manager: portage-2.2.8
Diffstat (limited to 'dev-python/pbr/pbr-0.5.21.ebuild')
-rw-r--r--dev-python/pbr/pbr-0.5.21.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pbr/pbr-0.5.21.ebuild b/dev-python/pbr/pbr-0.5.21.ebuild
new file mode 100644
index 0000000..1024015
--- /dev/null
+++ b/dev-python/pbr/pbr-0.5.21.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.21.ebuild,v 1.4 2013/11/12 06:06:21 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 python3_2 python3_3 pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">dev-python/pip-1.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}