aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2014-11-12 08:19:47 +0800
committerIan Delaney <della5@iinet.com.au>2014-11-12 08:19:47 +0800
commitb24237bedabd813dce7e2ad74695788609aa783e (patch)
treefaab34d14fadc34588ad6b83798efc0c5cebaf54 /dev-python/service_identity/service_identity-14.0.0.ebuild
parentnote for websocket-client in a diff file, add working service_identity, chara... (diff)
downloadimprovise-b24237bedabd813dce7e2ad74695788609aa783e.tar.gz
improvise-b24237bedabd813dce7e2ad74695788609aa783e.tar.bz2
improvise-b24237bedabd813dce7e2ad74695788609aa783e.zip
radical update
Package-Manager: portage-2.2.14
Diffstat (limited to 'dev-python/service_identity/service_identity-14.0.0.ebuild')
-rw-r--r--dev-python/service_identity/service_identity-14.0.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/service_identity/service_identity-14.0.0.ebuild b/dev-python/service_identity/service_identity-14.0.0.ebuild
deleted file mode 100644
index ec5a9d9..0000000
--- a/dev-python/service_identity/service_identity-14.0.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Service identity verification for pyOpenSSL"
-HOMEPAGE="https://github.com/pyca/service_identity"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE=" MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.12[${PYTHON_USEDEP}]
- >=dev-python/characteristic-14.0.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Prevent un-needed download during build
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test --cov service_identity --cov-report term-missing || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}