aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-16 00:54:15 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-16 00:54:15 +0800
commit3eac363043caeee993cde2d28bef7fe0714c3668 (patch)
tree385f929754af191357ba40b2cd532616ae368a9b /dev-python
parent[dev-python/django-*] set django to RDEPEND (diff)
downloadimprovise-3eac363043caeee993cde2d28bef7fe0714c3668.tar.gz
improvise-3eac363043caeee993cde2d28bef7fe0714c3668.tar.bz2
improvise-3eac363043caeee993cde2d28bef7fe0714c3668.zip
dev-python/[django-appconf,django-debug-toolbar,testfixtures] updates
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-appconf/django-appconf-0.5.ebuild3
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild2
-rw-r--r--dev-python/testfixtures/testfixtures-2.3.4.ebuild27
3 files changed, 17 insertions, 15 deletions
diff --git a/dev-python/django-appconf/django-appconf-0.5.ebuild b/dev-python/django-appconf/django-appconf-0.5.ebuild
index 8f9fd6a..b90a28b 100644
--- a/dev-python/django-appconf/django-appconf-0.5.ebuild
+++ b/dev-python/django-appconf/django-appconf-0.5.ebuild
@@ -10,7 +10,7 @@ RESTRICT_PYTHON_ABIS="2.5 3.*"
inherit distutils
DESCRIPTION="A helper class for handling configuration defaults of packaged apps gracefully"
-HOMEPAGE="http://pypi.python.org/pypi/django-appconf http://django-appconf.readthedocs.org//"
+HOMEPAGE="http://pypi.python.org/pypi/django-appconf http://django-appconf.readthedocs.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
@@ -37,7 +37,6 @@ src_test() {
testing() {
pushd build-${PYTHON_ABI}/lib > /dev/null
"$(PYTHON)" -m appconf.tests.tests
- einfo "tests completed for python"$(python_get_version)
popd > /dev/null
}
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild
index 6475169..ad3a6e8 100644
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-0.9.4.ebuild
@@ -33,7 +33,7 @@ src_test() {
# sys.path info output assures that tests.py is being run
testing() {
PYTHONPATH=. "$(PYTHON)" -m tests.tests
- einfo "Tests for python"$(python_get_version)" completed"
+ einfo "Tests for python$(python_get_version) completed"
einfo ""
}
python_execute_function testing
diff --git a/dev-python/testfixtures/testfixtures-2.3.4.ebuild b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
index 413c949..50f4443 100644
--- a/dev-python/testfixtures/testfixtures-2.3.4.ebuild
+++ b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
@@ -6,7 +6,7 @@ EAPI=4
PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="2.5 3.*"
-
+DISTUTILS_SRC_TEST="py.test" # hot off the press
inherit distutils eutils
DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
@@ -22,12 +22,13 @@ RDEPEND=""
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
# test? ( net-zope/zope-component )"
-# RED FLAG RED FLAG
src_prepare() {
sed -e s':SPHINXBUILD = ../bin/sphinx-build:SPHINXBUILD = /usr/bin/sphinx-build:' \
-i docs/Makefile
epatch "${FILESDIR}"/${P}-adjust_tests.patch
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
}
src_compile() {
distutils_src_compile
@@ -39,16 +40,18 @@ src_compile() {
# Tried using -m testfixtures/tests/ but the imports fluctuate dir levels. Need to use the patch
src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib/"
- pushd testfixtures/tests/ > /dev/null
- for test in test_*.py; do
- "$(PYTHON)" -m ${test/.py/} || die "${test}failed"
- einfo "Test "${test}" completed successfully"
- done
- popd > /dev/null
- }
- python_execute_function testing
+# testing() {
+# PYTHONPATH="${S}/build-${PYTHON_ABI}/lib/"
+# pushd testfixtures/tests/ > /dev/null
+# for test in test_*.py; do
+# py.test ${test}
+# "$(PYTHON)" ${test} || die "${test} failed"
+# done
+# popd > /dev/null
+# }
+# python_execute_function testing. perfect
+ py.test needs to be pointed to the tests folder
+ distutils_src_test ${PN}/tests/
}
src_install() {