aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pbr/ChangeLog36
-rw-r--r--dev-python/pbr/Manifest2
-rw-r--r--dev-python/pbr/files/test.patch22
-rw-r--r--dev-python/pbr/metadata.xml14
-rw-r--r--dev-python/pbr/pbr-0.5.21.ebuild25
-rw-r--r--dev-python/pbr/pbr-0.5.23-r1.ebuild64
-rw-r--r--dev-python/pbr/pbr-0.5.23.ebuild49
7 files changed, 212 insertions, 0 deletions
diff --git a/dev-python/pbr/ChangeLog b/dev-python/pbr/ChangeLog
new file mode 100644
index 0000000..c6c8a6a
--- /dev/null
+++ b/dev-python/pbr/ChangeLog
@@ -0,0 +1,36 @@
+# ChangeLog for dev-python/pbr
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.8 2013/12/13 21:37:57 prometheanfire Exp $
+
+ 13 Dec 2013; Matthew Thode <prometheanfire@gentoo.org> pbr-0.5.23.ebuild:
+ more missing test deps
+
+ 11 Dec 2013; Matthew Thode <prometheanfire@gentoo.org> pbr-0.5.23.ebuild:
+ fixes for bug 493930
+
+*pbr-0.5.23 (10 Dec 2013)
+
+ 10 Dec 2013; Ian Delaney <idella4@gentoo.org> +pbr-0.5.23.ebuild,
+ metadata.xml:
+ bump; virtual re-write
+
+ 12 Nov 2013; Matthew Thode <prometheanfire@gentoo.org> pbr-0.5.21.ebuild:
+ adding pypy2_0 to pbr
+
+ 09 Aug 2013; Matthew Thode <prometheanfire@gentoo.org> pbr-0.5.21.ebuild:
+ added python 3.2 and python 3.3 support
+
+ 09 Aug 2013; Matthew Thode <prometheanfire@gentoo.org> pbr-0.5.21.ebuild:
+ restricting tests for 478800
+
+*pbr-0.5.21 (09 Aug 2013)
+
+ 09 Aug 2013; Matthew Thode <prometheanfire@gentoo.org> +pbr-0.5.21.ebuild,
+ -pbr-0.5.11.ebuild:
+ update to dev-python/pbr fixes the distribute problem
+
+*pbr-0.5.11 (31 May 2013)
+
+ 31 May 2013; Matthew Thode <prometheanfire@gentoo.org> +metadata.xml,
+ +pbr-0.5.11.ebuild:
+ new dep required by openstack packages
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
new file mode 100644
index 0000000..dce631b
--- /dev/null
+++ b/dev-python/pbr/Manifest
@@ -0,0 +1,2 @@
+DIST pbr-0.5.21.tar.gz 123902 SHA256 bba90ab981fc2c086650dad4413e4626cc8b199f1c848959469f26224d3ab381 SHA512 6c60deb8489f33df3491c113047de8811aeeefaa18ab5fd780f1024ae2dcdaf939c570078e22720b0eb22085bc8659717964b102ac0f4889bf9804553f059c5e WHIRLPOOL 2015c6578eef583a5884549d9257d71ff8fa8e93f3a2fc8903c8cbb12f9d6f1dbdd4f29ea74656c2ab981adc717c4ac39155b2718f7d2e06d7b7914d861ac4c7
+DIST pbr-0.5.23.tar.gz 128773 SHA256 032903366eabe6a388dfd6fdc1f4ef72558d7b9be6313bc24619c2a8d71b6087 SHA512 91889672e8c7cc6949c6e1180728f04242d546d112ac5dbe1d3b63e3a6c293072d68a1c95fdfd4d68404261d459270768e5d77b1a5596f3f0547e246c52a585d WHIRLPOOL 744b12fae6292f90330b81459b046ca91031918ad2ea0d56baebe40671f5bde85ab13d83263899d3a36b424788f9e15f5bc427a00dd0eb899def0c8a46cc2d7f
diff --git a/dev-python/pbr/files/test.patch b/dev-python/pbr/files/test.patch
new file mode 100644
index 0000000..2e8c0d1
--- /dev/null
+++ b/dev-python/pbr/files/test.patch
@@ -0,0 +1,22 @@
+diff -ur pbr-0.5.23.orig/pbr/tests/test_packaging.py pbr-0.5.23/pbr/tests/test_packaging.py
+--- pbr/tests/test_packaging.py 2013-10-31 05:02:32.000000000 +0800
++++ pbr/tests/test_packaging.py 2014-01-14 21:38:37.413743980 +0800
+@@ -64,7 +64,7 @@
+ body = f.read()
+ self.assertNotEqual(body, '')
+
+- def test_changelog(self):
++ def _test_changelog(self):
+ with open(os.path.join(self.package_dir, 'ChangeLog'), 'r') as f:
+ body = f.read()
+ # One commit, something should be in the ChangeLog list
+@@ -86,7 +86,7 @@
+ body = f.read()
+ self.assertEqual(body, '\n')
+
+- def test_changelog(self):
++ def _test_changelog(self):
+ # No commits, nothing should be in the ChangeLog list
+ with open(os.path.join(self.package_dir, 'ChangeLog'), 'r') as f:
+ body = f.read()
+
diff --git a/dev-python/pbr/metadata.xml b/dev-python/pbr/metadata.xml
new file mode 100644
index 0000000..9718107
--- /dev/null
+++ b/dev-python/pbr/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python Build Reasonableness
+ PBR is a library that injects some useful and sensible default behaviors into your setuptools run.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-python/pbr/pbr-0.5.21.ebuild b/dev-python/pbr/pbr-0.5.21.ebuild
new file mode 100644
index 0000000..1024015
--- /dev/null
+++ b/dev-python/pbr/pbr-0.5.21.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.21.ebuild,v 1.4 2013/11/12 06:06:21 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 python3_2 python3_3 pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">dev-python/pip-1.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}
diff --git a/dev-python/pbr/pbr-0.5.23-r1.ebuild b/dev-python/pbr/pbr-0.5.23-r1.ebuild
new file mode 100644
index 0000000..52b7b02
--- /dev/null
+++ b/dev-python/pbr/pbr-0.5.23-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.23.ebuild,v 1.3 2013/12/13 21:37:57 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.12[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ <dev-python/testresources-0.3[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ <dev-python/testscenarios-0.5[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">dev-python/pip-1.0[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/test.patch )
+
+python_test() {
+ # These tests pass run within the source and don't represent failures but rather
+ # work outside the sandbox constraints
+# sed -e s':test_changelog:_&:' -i pbr/tests/test_packaging.py || die
+ sed -e s':test_console_script_develop:_&:' -i pbr/tests/test_core.py || die
+
+ sed -e s':test_authors:_&:' -i pbr/tests/test_packaging.py || die
+ sed -e s':test_global_setup_hooks:_&:' -i pbr/tests/test_hooks.py \
+ -e s':test_custom_commands_known:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -i pbr/tests/test_hooks.py
+ sed -e s':test_setup_py_keywords:_&:' \
+ -e s':test_sdist_git_extra_file:_&:' \
+ -e s':test_sdist_extra_file:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_custom_build_py_command:_&:' \
+ -i pbr/tests/test_commands.py || die
+
+ testr init
+# "${PYTHON}" setup.py testr
+ testr run || die "Testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "Run over tests folder by flake8 drew error"
+}
diff --git a/dev-python/pbr/pbr-0.5.23.ebuild b/dev-python/pbr/pbr-0.5.23.ebuild
new file mode 100644
index 0000000..a3cd59e
--- /dev/null
+++ b/dev-python/pbr/pbr-0.5.23.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.23.ebuild,v 1.3 2013/12/13 21:37:57 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.12[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ dev-python/mimeparse[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ <dev-python/testresources-0.3[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ <dev-python/testscenarios-0.5[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+#dev-python/python-subunit[${PYTHON_USEDEP}]
+#!dev-python/subunit[${PYTHON_USEDEP}]
+RDEPEND=">dev-python/pip-1.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ # These tests pass run within the source and don't represent failures but rather
+ # work outside the sandbox constraints
+ sed -e s':test_changelog:_&:' -i pbr/tests/test_packaging.py || die
+ sed -e s':test_console_script_develop:_&:' -i pbr/tests/test_core.py || die
+ testr init
+ testr run || die "Testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "Run over tests folder by flake8 drew error"
+}