aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/bottle/Manifest1
-rw-r--r--dev-python/bottle/bottle-0.10.9.ebuild57
-rw-r--r--dev-python/bottle/files/bottle-0.10.9-python3tests.patch13
-rw-r--r--dev-python/bottle/files/bottle-0.10.9-test.patch83
-rw-r--r--dev-python/bottle/metadata.xml14
-rw-r--r--dev-python/mwlib/mwlib-0.13.7.ebuild4
-rw-r--r--dev-python/testify/Manifest1
-rw-r--r--dev-python/testify/testify-0.2.4.ebuild37
8 files changed, 0 insertions, 210 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
deleted file mode 100644
index 9dab7c1..0000000
--- a/dev-python/bottle/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST bottle-0.10.9.tar.gz 55771 SHA256 bfe88bcf920880d9c355f58b651a97e7f8b56437b104ff951fb985a129c06794 SHA512 0e8ef787b6cc7a0f527af1ec4cf3929a8eafc694eb24c24e4e86d60c28432643d0aed4c014f4c6375661d52a57f7216ea3693879599848d72dce9e1777fa762e WHIRLPOOL 48eba826b2f40d85808420e1c825c1c5b35705b03447d7a64095558637f68c8d2900a441ead26f2909bfea417f4e411e2fa026805b0db7f51411770f81703fac
diff --git a/dev-python/bottle/bottle-0.10.9.ebuild b/dev-python/bottle/bottle-0.10.9.ebuild
deleted file mode 100644
index c698ec3..0000000
--- a/dev-python/bottle/bottle-0.10.9.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-appconf/django-appconf-0.5.ebuild,v 1.1 2012/04/25 12:25:31 tampakrap Exp $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="A fast and simple micro-framework for small web-applications"
-HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-PYTHON_MODNAME=bottle.py
-
-RDEPEND="dev-python/simplejson"
-DEPEND="${RDEPEND} dev-python/setuptools"
-
-src_prepare() {
- distutils_src_prepare
-
- sed -e "/^sys.path.insert/d" -i test/{servertest.py,testall.py} || die
- epatch "${FILESDIR}"/bottle-0.10.9-python3tests.patch
-}
-
-src_test() {
- testing() {
- if [[ $(python_get_version --major) == 3 ]]; then
- # test/views are templates, data files, not copied over
- cp -a test/views/ build-${PYTHON_ABI}/lib/test/ || die "data file did not copy"
- pushd build-${PYTHON_ABI}/lib/ > /dev/null
- PYTHONPATH=. "$(PYTHON)" test/testall.py
- popd > /dev/null
- else
- # folder test in ${S} is Python2 compliant
- PYTHONPATH="build-${PYTHON_ABI}/lib/" "$(PYTHON)" test/testall.py
- fi
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- # Remove un-needed tests to avoid file collisions
- rmtests() {
- rm -rf ${ED}/$(python_get_sitedir)/test/ || die
- }
- python_execute_function -q rmtests
-}
diff --git a/dev-python/bottle/files/bottle-0.10.9-python3tests.patch b/dev-python/bottle/files/bottle-0.10.9-python3tests.patch
deleted file mode 100644
index de8a2a8..0000000
--- a/dev-python/bottle/files/bottle-0.10.9-python3tests.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur bottle-0.10.9.orig/setup.py bottle-0.10.9/setup.py
---- setup.py 2012-02-12 02:43:46.000000000 +0800
-+++ setup.py 2012-05-19 00:25:44.750914193 +0800
-@@ -40,7 +40,8 @@
- 'Topic :: Software Development :: Libraries :: Application Frameworks',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 3'],
-- cmdclass = {'build_py': build_py}
-+ cmdclass = {'build_py': build_py},
-+ packages=["test"]
- )
-
-
diff --git a/dev-python/bottle/files/bottle-0.10.9-test.patch b/dev-python/bottle/files/bottle-0.10.9-test.patch
deleted file mode 100644
index d296ab8..0000000
--- a/dev-python/bottle/files/bottle-0.10.9-test.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-# https://github.com/defnull/bottle/issues/323
-# 1) Upstream set root = os.path.abspath(root) + os.sep in bottle.py.
-# Subsequently relative path ./views needs "${S}"/test/views in test/test_jinja2.py
-# 2) ZeroDivisionError is absent from whatever file is tested in the test in test/test_outputfilter.py
-# Subsequently ZeroDivisionError -> Internal Server Error which is error 500 in the page.
-# 3)''' The virtual module needs a valid __file__ attribute.
-# If not, the Google app engine development server crashes on windows.'''
-# Linux isn't Windows so it's not required and the test suite does NOT warrant being held
-# to ransom over an irrelevant and trivial test.
-# That aside, the func DOES appear to allocate __file__ attribute.
-
-diff -ur
-bottle-0.10.9.orig/test/test_importhook.py
-bottle-0.10.9/test/test_importhook.py
---- test/test_importhook.py 2011-12-23 23:00:02.000000000 +0800
-+++ test/test_importhook.py 2012-05-13 21:49:29.377737727 +0800
-@@ -31,13 +31,6 @@
- def test():
- import bottle.ext.doesnotexist
- self.assertRaises(ImportError, test)
--
-- def test_ext_isfile(self):
-- ''' The virtual module needs a valid __file__ attribute.
-- If not, the Google app engine development server crashes on windows.
-- '''
-- from bottle import ext
-- self.assertTrue(os.path.isfile(ext.__file__))
-
- if __name__ == '__main__': #pragma: no cover
- unittest.main()
-diff -ur bottle-0.10.9.orig/test/test_outputfilter.py bottle-0.10.9/test/test_outputfilter.py
---- test/test_outputfilter.py 2012-02-12 02:43:46.000000000 +0800
-+++ test/test_outputfilter.py 2012-05-13 21:54:21.027744474 +0800
-@@ -36,7 +36,7 @@
- def test_error(self):
- self.app.route('/')(lambda: 1/0)
- self.assertStatus(500)
-- self.assertInBody('ZeroDivisionError')
-+ self.assertInBody('Internal Server Error')
-
- def test_fatal_error(self):
- @self.app.route('/')
-@@ -107,7 +107,7 @@
- def test():
- yield 1/0
- self.assertStatus(500)
-- self.assertInBody('ZeroDivisionError')
-+ self.assertInBody('Internal Server Error')
-
- def test_fatal_error_in_generator_callback(self):
- @self.app.route('/')
-# Tricky this: For some low level reason the use of a patch skirts the very purpose of the patch
-# i.e. to use the abs "${S}"; Use of the patch skirts the bash expansion, yielding
-#"${S}"/test/views/jinja2_simple.tpl
-# Use of sed sees the bash expansion take place
-#diff -ur bottle-0.10.9.orig/test/test_jinja2.py bottle-0.10.9/test/test_jinja2.py
-#--- test/test_jinja2.py 2012-02-12 02:43:46.000000000 +0800
-#+++ test/test_jinja2.py 2012-05-13 21:51:51.954740875 +0800
-#diff -ur bottle-0.10.9.orig/test/test_outputfilter.py bottle-0.10.9/test/test_outputfilter.py
-#@@ -12,12 +12,12 @@
-#
-# def test_file(self):
-# """ Templates: Jinja2 file"""
-#- t = Jinja2Template(name='./views/jinja2_simple.tpl').render(var='var')
-#+ t = Jinja2Template(name='${S}/test/views/jinja2_simple.tpl').render(var='var')
-# self.assertEqual('start var end', ''.join(t))
-#
-# def test_name(self):
-# """ Templates: Jinja2 lookup by name """
-#- t = Jinja2Template(name='jinja2_simple', lookup=['./views/']).render(var='var')
-#+ t = Jinja2Template(name='jinja2_simple', lookup=['"${S}"/test/views/']).render(var='var')
-# self.assertEqual('start var end', ''.join(t))
-#
-# def test_notfound(self):
-#@@ -30,7 +30,7 @@
-#
-# def test_inherit(self):
-# """ Templates: Jinja2 lookup and inherience """
-#- t = Jinja2Template(name='jinja2_inherit', lookup=['./views/']).render()
-#+ t = Jinja2Template(name='jinja2_inherit', lookup=['"${S}"/test/views/']).render()
-# self.assertEqual('begin abc end', ''.join(t))
-#
-# def test_custom_filters(self):
diff --git a/dev-python/bottle/metadata.xml b/dev-python/bottle/metadata.xml
deleted file mode 100644
index 472ba46..0000000
--- a/dev-python/bottle/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer>
- <email>johneed@hotmail.com</email>
- <name>Ian Delaney</name>
- </maintainer>
- <maintainer>
- <email>tampakrap@gentoo.org</email>
- <name>Theo Chatzimichos</name>
- </maintainer>
- <herd>python</herd>
-</pkgmetadata>
-
diff --git a/dev-python/mwlib/mwlib-0.13.7.ebuild b/dev-python/mwlib/mwlib-0.13.7.ebuild
index 1dd4ea2..e94fdee 100644
--- a/dev-python/mwlib/mwlib-0.13.7.ebuild
+++ b/dev-python/mwlib/mwlib-0.13.7.ebuild
@@ -26,7 +26,6 @@ RDEPEND="dev-python/lxml
>=dev-python/timelib-0.2
virtual/latex-base
|| ( dev-lang/python:2.7 dev-lang/python:2.6 >=dev-python/simplejson-2.5 )
- >=dev-python/simplejson-2.5
dev-python/gevent
>=dev-python/bottle-0.10
dev-python/apipkg
@@ -80,8 +79,5 @@ src_install() {
distutils_src_install
if use doc; then
dohtml -r docs/_build/html/
- docompress -x usr/share/doc/${P}/doctrees/
- insinto usr/share/doc/${P}/
- doins -r docs/_build/doctrees
fi
}
diff --git a/dev-python/testify/Manifest b/dev-python/testify/Manifest
deleted file mode 100644
index 3414ca5..0000000
--- a/dev-python/testify/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST testify-0.2.4.tar.gz 44584 SHA256 681423a89c7d0a10d6672c023d9e087c5b875e09c6562dd9eda8bdb8bb99593e SHA512 89c4b6c67c66ebcd9838d10761b66c70d79105768e29dc486c7a035afe1c197e29e1c2ee5e2249f3d35f6eb67960b0db6a78bfb793335e2f5017cb17b1c47a5e WHIRLPOOL 31b65f6c5dab4c0b95558cf96909ae1de569f5ee71def519b9ed90e79e96a81cc2e730db2b0e57c8ce456f084d784e04756241ccb9f23f269e6aa051b5ed4206
diff --git a/dev-python/testify/testify-0.2.4.ebuild b/dev-python/testify/testify-0.2.4.ebuild
deleted file mode 100644
index ea252f9..0000000
--- a/dev-python/testify/testify-0.2.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-#RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-DESCRIPTION="A Testing Framework"
-HOMEPAGE="http://pypi.python.org/pypi/testify http://github.com/Yelp/Testify"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${RDEPEND} dev-python/setuptools
- test? ( www-servers/tornado )"
-
-src_prepare() {
- sed -e s':srv._socket:srv.add_socket:' -i test/plugins/http_reporter_test.py
-}
-
-src_test() {
- testing() {
- pushd test > /dev/null
-# "$(PYTHON)" ../bin/testify test
- PYTHONPATH="../build-${PYTHON_ABI}/lib:"${S}":." "$(PYTHON)" ../bin/testify test
- popd > /dev/null
- }
- python_execute_function testing
-}