aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bottle/bottle-0.10.9.ebuild')
-rw-r--r--dev-python/bottle/bottle-0.10.9.ebuild37
1 files changed, 7 insertions, 30 deletions
diff --git a/dev-python/bottle/bottle-0.10.9.ebuild b/dev-python/bottle/bottle-0.10.9.ebuild
index 412b377..b81bf22 100644
--- a/dev-python/bottle/bottle-0.10.9.ebuild
+++ b/dev-python/bottle/bottle-0.10.9.ebuild
@@ -7,10 +7,10 @@ PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="A fast and simple micro-framework for small web-applications"
-HOMEPAGE="http://pypi.python.org/pypi/bottle"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64"
IUSE=""
@@ -22,39 +22,16 @@ PYTHON_MODNAME=bottle.py
RDEPEND=""
DEPEND="${RDEPEND} dev-python/setuptools"
-# dev friendly commentary; 1) They set root = os.path.abspath(root) + os.sep in bottle.py
-# Subsequently relative path ./views needs sed -> ${S}/test/views in test/test_jinja2.py
-# 2) ZeroDivisionError is absent from whatever file is tested in the test in test/test_outputfilter.py
-# Subsequently ZeroDivisionError -> Internal Server Error which is error 500 in the page.
-# 3)''' The virtual module needs a valid __file__ attribute.
-# If not, the Google app engine development server crashes on windows.'''
-# well linux isn't windows so it's not required for 'us' and the test suite does NOT warrant being held
-# to ransom over an irrelevant and trivial test. That aside, the func DOES appear to allocate __file__ attribute.
-# Yet another upstream issue to file.
-
src_prepare() {
- sed -e "s:./views:${S}/test/views:" -i test/test_jinja2.py || return
- sed -e 's:ZeroDivisionError:Internal Server Error:g' -i test/test_outputfilter.py || return
- sed -e "s/ self.assertTrue/# self.assertTrue/" -i test/test_importhook.py || return
+ # Use of the patch skirts the bash expansion
+ sed -e "s:./views:"${S}"/test/views:" -i test/test_jinja2.py || return
+ epatch "${FILESDIR}"/${P}-test.patch
}
-# more dev friendly commentary; 1 bottle.py; many test_file.py s.
-# This works for python2.7 since discovery is new && unique to it.
-#src_test() {
-# PYTHONPATH=.:test:$EROOT
-# testing() {
-# $(PYTHON) -m unittest discover test
-# }
-# python_execute_function testing
-#}
-
-# This generic approach works with coverage output. nosetests pulls errors which this doesn't in the same tests.
-
+# This generic approach works with coverage output.
src_test() {
testing() {
- local exit_status=0
- $(PYTHON) -d -m test/testall || exit_status=1
- return $exit_status
+ $(PYTHON) -d -m test/testall
}
python_execute_function testing
}