aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
index cf26fa0..6fd8e87 100644
--- a/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
@@ -26,20 +26,16 @@ DEPEND="${RDEPEND} >=dev-python/django-1.0
src_compile() {
distutils_src_compile
+
# BuildDocs is not essential. just an extra 'touch'
- BuildDocs() {
- emake -C docs html
- }
- if use doc; then
- python_execute_function -f BuildDocs
- fi
+ use doc && emake -C docs html
}
src_test() {
export DJANGO_SETTINGS_MODULE="django.conf"
# Test && demo that the tests are run;
- # Python.[56] trigger a hramless depracation warning
+ # Python.[56] trigger a harmless depracation warning
testing() {
local exit_status=0
PYTHONPATH=build-${PYTHON_ABI}/lib