aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-evolution/django-evolution-0.6.7.ebuild')
-rw-r--r--dev-python/django-evolution/django-evolution-0.6.7.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/django-evolution/django-evolution-0.6.7.ebuild b/dev-python/django-evolution/django-evolution-0.6.7.ebuild
deleted file mode 100644
index e240cb2..0000000
--- a/dev-python/django-evolution/django-evolution-0.6.7.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils eutils
-
-MY_P=${PN/-/_}-${PV}
-
-#MY_PN="${MY_P}-${PV}"
-DESCRIPTION="A Django application that will run cron jobs for other django apps"
-HOMEPAGE="http://code.google.com/p/django-evolution/ http://pypi.python.org/pypi/django_evolution/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}/${MY_P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-LICENSE="BSD"
-SLOT="0"
-PYTHON_MODNAME="django_evolution"
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- dev-python/django"
-
-src_test() {
- # pypy registers 2 fails but does not return non zeros status and carries on!!!
- testing() {
- local exit_status=0
- "$(PYTHON)" tests/runtests.py || exit_status=1
- return $exit_status
- }
- python_execute_function testing
-}
-
-src_install() {
- local msg="Remove tests to avoid file collisions"
- distutils_src_install
-
- rmtests() {
- rm -rf ${ED}/$(python_get_sitedir)/tests/ || die
- }
- python_execute_function --action-message "$msg" rmtests
- dodoc docs/*
-}