summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/armory/armory-9999.ebuild')
-rw-r--r--net-misc/armory/armory-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/armory/armory-9999.ebuild b/net-misc/armory/armory-9999.ebuild
new file mode 100644
index 0000000..6970bf8
--- /dev/null
+++ b/net-misc/armory/armory-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2
+
+DESCRIPTION="Armory is an advanced Bitcoin client"
+HOMEPAGE="http://bitcoinarmory.com/"
+
+EGIT_REPO_URI="git://github.com/etotheipi/BitcoinArmory.git"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="net-p2p/bitcoin-qt"
+
+DEPEND="dev-python/PyQt4
+ dev-lang/swig
+ dev-python/twisted
+ x11-misc/xdg-utils"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
+
+pkg_postinst() {
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryofflineicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_green_64x64.png armorytestneticon
+}