summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2013-12-30 15:03:28 -0500
committerJustin Riley <justin.t.riley@gmail.com>2014-03-13 13:45:44 -0400
commit3aac6151659f7122cdd1fe12b59cfd2fef0b526b (patch)
tree0c91eb0d79521891e9a91f05a7f405059712c09b
parentnixnote: bump ebuild to version 1.6 (diff)
downloadjtriley-3aac6151659f7122cdd1fe12b59cfd2fef0b526b.tar.gz
jtriley-3aac6151659f7122cdd1fe12b59cfd2fef0b526b.tar.bz2
jtriley-3aac6151659f7122cdd1fe12b59cfd2fef0b526b.zip
add gizmod live ebuild
-rw-r--r--app-misc/gizmod/ChangeLog61
-rw-r--r--app-misc/gizmod/files/gizmod.rc21
-rw-r--r--app-misc/gizmod/gizmod-9999.ebuild77
-rw-r--r--app-misc/gizmod/metadata.xml9
4 files changed, 168 insertions, 0 deletions
diff --git a/app-misc/gizmod/ChangeLog b/app-misc/gizmod/ChangeLog
new file mode 100644
index 0000000..a63cea2
--- /dev/null
+++ b/app-misc/gizmod/ChangeLog
@@ -0,0 +1,61 @@
+# ChangeLog for app-misc/gizmod
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 12 Dec 2009; Justin Riley <justin.t.riley@gmail.com> gizmod-3.5.ebuild,
+ +files/gizmod-3.5-gcc44.patch:
+ Added patch for gcc 4.4.2, bug submitted upstream
+
+ 27 Nov 2009; Justin Riley <justin.t.riley@gmail.com> gizmod-3.5.ebuild,
+ +files/gizmod-3.5-libvisual.patch:
+ Added patch to enforce libvisual USE flag. Thanks to Tommy[D] for the catch
+
+ 25 Nov 2009; Justin Riley <justin.t.riley@gmail.com> gizmod-3.5.ebuild,
+ +files/gizmod.rc:
+ Added init script, changed LIB_INSTALL_DIR to LIB_SUFFIX which removed need
+ to inherit multilib, fixed boost DEPEND/RDEPEND for older versions of boost
+ which did not have python use flag, removed version specific dep on
+ libvisual. Thanks to ohnobikini, ABCD_, bonsaikitten, and Tommy[D] for
+ review.
+
+ 18 Nov 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -gizmod-3.3.ebuild, gizmod-3.5.ebuild:
+ Nuke old version, add missing multilib eclass
+
+ 15 Nov 2009; Justin Riley <justin.t.riley@gmail.com> +gizmod-3.5.ebuild:
+ New Ebuild for bug 134016, thanks to ak for initial ebuild and Tommy,
+ ohnobikini, and dilfridge for review
+
+ 16 Mar 2009; Nick Fortino (nfortino) <nfortino@gmail.com>
+ gizmod-3.3.ebuild:
+ Update ebuild to use EAPI 2. Thanks to Cristian Ruppert and Thomas Sachau
+ for review
+
+ 23 Aug 2008; Thomas Beierlein (TomJBE) <tb@forth-ev.de> metadata.xml:
+ Added USE flag description wrt GLEP 56
+
+ 18 Jan 2008; (Tommy[D]) tommy100@gmx.de gizmod-3.3.ebuild:
+ Shorten DESCRIPTION
+
+ 28 Jun 2007; Tim Burrell <tim.burrell@gmail.com> -gizmod-3.2.ebuild,
+ ,gizmod-3.3.ebuild:
+ Fix Manifest and Digest for tarball on sourceforge, and remove old ebuild
+
+ 27 Jun 2007; Tim Burrell <tim.burrell@gmail.com> +gizmod-3.3.ebuild:
+ New Ebuild for bug 134016
+
+ 20 Jun 2007; Jakub Moc <jakub@gentoo.org> gizmod-3.2.ebuild:
+ Fix built_with_use check for newer boost versions
+
+ 04 Jun 2007; Tim Burrell <tim.burrell@gmail.com> -gizmod-3.1.ebuild,
+ +gizmod-3.2.ebuild:
+ New Ebuild for bug 134016
+
+ 17 May 2007; Tim Burrell <tim.burrell@gmail.com> -gizmod-3.0.ebuild,
+ +gizmod-3.1.ebuild:
+ New Ebuild for bug 134016
+
+ 09 May 2007; Your Name (flithm) <tim@timburrell.net> +gizmod-3.0.ebuild,
+ +metadata.xml:
+ New Ebuild for bug 134016
+
diff --git a/app-misc/gizmod/files/gizmod.rc b/app-misc/gizmod/files/gizmod.rc
new file mode 100644
index 0000000..86f27d3
--- /dev/null
+++ b/app-misc/gizmod/files/gizmod.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ after alsasound
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --background --make-pidfile --pidfile /var/run/gizmod.pid \
+ --exec /usr/bin/gizmod -- ${GIZMOD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile /var/run/gizmod.pid
+ eend $?
+}
diff --git a/app-misc/gizmod/gizmod-9999.ebuild b/app-misc/gizmod/gizmod-9999.ebuild
new file mode 100644
index 0000000..b20a2f9
--- /dev/null
+++ b/app-misc/gizmod/gizmod-9999.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit git-2 python cmake-utils linux-info
+
+DESCRIPTION="Input event scripting utility that has special support for fancy keyboards, mice, USB dials and more"
+HOMEPAGE="http://gizmod.sourceforge.net"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/jtriley/gizmod.git"
+EGIT_BRANCH="develop"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libvisual"
+RDEPEND="x11-libs/libXext
+ amd64? ( >=dev-libs/boost-1.36[python] )
+ || ( dev-libs/boost:0 dev-libs/boost[python] )
+ x11-libs/libICE
+ media-libs/alsa-lib
+ libvisual? ( media-libs/libvisual )"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="INPUT_EVDEV INOTIFY_USER"
+
+ERROR_INPUT_EVDEV="
+Gizmo Daemon needs input evdev support from the kernel.
+Please select \"Event interface\" (CONFIG_INPUT_EVDEV) under
+\"Device Drivers->Input Device Support->Event interface\".
+This option can be built directly into the kernel or as
+a module.
+"
+
+ERROR_INOTIFY="
+Gizmo Daemon needs inotify support built into the kernel.
+Please select \"Inotify file change notifification\"
+(CONFIG_INOTIFY) under \"Device Drivers->File systems\". This
+option can only be built directly into the kernel.
+"
+
+ERROR_INOTIFY_USER="
+Gizmo Daemon needs userspace inotify support built into the kernel.
+Please select \"Inotify file change notifification\"
+(CONFIG_INOTIFY) followed by \"Inotify support for userspace\"
+(CONFIG_INOTIFY_USER) under \"Device Drivers->File systems\". These
+options can only be built directly into the kernel.
+"
+
+src_unpack() {
+ git-2_src_unpack
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i CMakeLists.txt -e /DefineInstallationPaths/d || die "sed: removal of DefineInstallationPaths failed"
+ sed -i libGizmod/CMakeLists.txt -e 's:lib$:lib${LIB_SUFFIX}:' || die "sed: replacing lib with LIB_INSTALL_DIR failed"
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DSYSCONF_INSTALL_DIR=${EPREFIX}/etc
+ -DBOOST_PYTHON_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libboost_python-${PYTHON_ABI}-mt.so
+ $(cmake-utils_use_build libvisual VIS_PLUGIN)
+ "
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}/gizmod.rc" gizmod || die "init script install failed"
+}
diff --git a/app-misc/gizmod/metadata.xml b/app-misc/gizmod/metadata.xml
new file mode 100644
index 0000000..f6d454f
--- /dev/null
+++ b/app-misc/gizmod/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+ <use>
+ <flag name='libvisual'>Enable the <pkg>media-libs/libvisual</pkg> (Amarok) plugin</flag>
+ </use>
+</pkgmetadata>