summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-04-09 11:58:19 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-04-09 11:58:19 -0400
commitab5d03122c3f8ebed30a30bab4530f33bd485b40 (patch)
tree3d26b3284470c42dcac60a419085fb9b5ae1d0c2
parentcmake-2.8.12.2: fix ncurses tinfo bug #468622 (diff)
downloadjtriley-ab5d03122c3f8ebed30a30bab4530f33bd485b40.tar.gz
jtriley-ab5d03122c3f8ebed30a30bab4530f33bd485b40.tar.bz2
jtriley-ab5d03122c3f8ebed30a30bab4530f33bd485b40.zip
starcluster: add ebuild for latest 0.95.4 release
-rw-r--r--dev-python/starcluster/Manifest1
-rw-r--r--dev-python/starcluster/starcluster-0.95.4.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/starcluster/Manifest b/dev-python/starcluster/Manifest
index dc3c7a1..f98bb13 100644
--- a/dev-python/starcluster/Manifest
+++ b/dev-python/starcluster/Manifest
@@ -1 +1,2 @@
DIST StarCluster-0.95.3.tar.gz 2388166 SHA256 f88efabd4f4b0d4ac3de4f5199d10165bf07427c541ef8b6f3ba5bc53098175b SHA512 90e234fe37492fcab2be1aa043eecd38ea3fed4767fc55ceff4055b421fac6d8df726f0ec0bc5c612dd8a9add84cf9afd20f086d7ae2bca89c4490608a52b610 WHIRLPOOL a2188a79f49f65a07cd2745bea7b4ee401e5a8902f9c2f906e903bef7f4875afd4a836eb4082309713922babe111b44b8cafe3261ee259ec90c95ff2d6077148
+DIST StarCluster-0.95.4.tar.gz 2378552 SHA256 05102b3658e2a074fc9d8a87766024c8b678bda6149f9b4ff98c83a4eca89d72 SHA512 a350fb07a2f352ef1b9f272bcf359f13f0ce58312a4869065ceec9c8467ebc4a319a12e24d065ca37d8b213b7cdd23cdd7cb336b130971ec48b55bff3653bfd4 WHIRLPOOL 2a3c8b873655e4d6b5842502573b22c1b6d7deb80b518f39ab286e346d90d911abfc8fab8182432593d6d663c56d05495ced0103e092e5e0b6c13e77b32982ce
diff --git a/dev-python/starcluster/starcluster-0.95.4.ebuild b/dev-python/starcluster/starcluster-0.95.4.ebuild
new file mode 100644
index 0000000..52d9a85
--- /dev/null
+++ b/dev-python/starcluster/starcluster-0.95.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: dev-python/starcluster-0.95.3.ebuild 2014/03/20 jtriley
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_SRC_TEST="py.test"
+
+inherit distutils-r1 bash-completion-r1
+
+MY_PN=StarCluster
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="StarCluster is a Cluster Computing Toolkit for the Cloud (EC2)."
+HOMEPAGE="http://star.mit.edu/cluster"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc bash-completion epydoc"
+
+RDEPEND=">=dev-python/paramiko-1.12.1[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.23.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/workerpool-0.9.2[${PYTHON_USEDEP}]
+ >=dev-python/iptools-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.8[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.5[${PYTHON_USEDEP}]
+ >=dev-python/scp-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/optcomplete-1.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-issuetracker[${PYTHON_USEDEP}]
+ dev-python/epydoc[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ use doc && emake -C docs/sphinx html
+ mkdocs() {
+ local exit_status=0
+ local msg="build with epydoc failed"
+ pushd docs/epydoc/
+ PATH=$PATH:./ PYTHONPATH="${BUILD_DIR}/lib" ./build.sh || exit_status=1
+ [[ $exit_status != 0 ]] && eerror "$msg"
+ popd sets
+ return $exit_status
+ }
+ use epydoc && mkdocs
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use bash-completion && newbashcomp completion/${PN}-completion.sh ${PN}
+ use doc && local HTML_DOCS=( docs/sphinx/_build/html/. )
+ if use epydoc; then
+ docompress -x usr/share/doc/${PF}/apidocs/api-objects.txt
+ insinto usr/share/doc/${PF}/
+ doins -r "${S}"/docs/apidocs/
+ fi
+}
+
+python_test() {
+ py.test || die -v ${PN}/tests || die
+}