summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/scp/Manifest1
-rw-r--r--dev-python/scp/scp-0.7.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/scp/Manifest b/dev-python/scp/Manifest
new file mode 100644
index 0000000..2fc97c1
--- /dev/null
+++ b/dev-python/scp/Manifest
@@ -0,0 +1 @@
+DIST scp-0.7.1.tar.gz 5412 SHA256 30c42e1cc828dd207d745b06f961839d816a7f07eb5823320ce0ac50b91ce7d9 SHA512 49f3325e584806445568f2ec3006b0c69dcd49e237325e4fb55f618d456a50bf9692af891f686dd39f566381929c98f6e33f7d3722a6c272309ba7489ce739b5 WHIRLPOOL 278505bae63cfc1bf30d743139e221ebb68b1a5fcfa7d8aa7b5f7dae177f2d0bf8b9b120ae4ac5379b196b5e20abb336c91c02eeaf976614de785ca976bf3d2f
diff --git a/dev-python/scp/scp-0.7.1.ebuild b/dev-python/scp/scp-0.7.1.ebuild
new file mode 100644
index 0000000..809e676
--- /dev/null
+++ b/dev-python/scp/scp-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 bash-completion-r1
+MY_PN=scp
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="SCP module for Paramiko"
+HOMEPAGE="https://github.com/jbardin/scp.py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"