summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaroslav Hron <jaroslav.hron@mff.cuni.cz>2011-11-04 14:32:16 +0100
committerJaroslav Hron <jaroslav.hron@mff.cuni.cz>2011-11-04 14:32:16 +0100
commit1ddcce07b80cb5d3b224d01a48476af94018bf84 (patch)
tree0be86d4be78fcd79b5c1cd28e822172ed9f62be2
parentmendeleydesktop 1.1.3 (diff)
downloadjxh-1ddcce07b80cb5d3b224d01a48476af94018bf84.tar.gz
jxh-1ddcce07b80cb5d3b224d01a48476af94018bf84.tar.bz2
jxh-1ddcce07b80cb5d3b224d01a48476af94018bf84.zip
add the ebuild for 1.1.3
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-1.1.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-1.1.3.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-1.1.3.ebuild
new file mode 100644
index 0000000..2fc8059
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-1.1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="http://s3.amazonaws.com/mendeley-desktop-download/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+RDEPEND="dev-libs/openssl:0.9.8
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:1.2"
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu "share/applications/${PN}.desktop"
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto "/usr/share/icons/hicolor/${res}/apps"
+ doins "share/icons/hicolor/${res}/apps/${PN}.png" || \
+ die "Installing icons failed."
+ done
+ insinto "/usr/share/pixmaps"
+ doins "share/icons/hicolor/48x48/apps/${PN}.png" || \
+ die "Installing pixmap failed."
+
+ # dodoc
+ dodoc "share/doc/${PN}/"* || die "Installing docs failed."
+
+ # create directories for installation
+ dodir ${MENDELEY_INSTALL_DIR} || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/lib" || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/share" || die "dodir failed"
+
+ # install binaries
+ mv "bin" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing bin failed."
+ mv "lib" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing libs failed."
+ mv "share/${PN}" "${D}${MENDELEY_INSTALL_DIR}/share" || \
+ die "Installing shared files failed."
+ dosym "${MENDELEY_INSTALL_DIR}/bin/${PN}" "/opt/bin/${PN}" || \
+ die "Installing launcher symlinks failed."
+}
+