summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bup/files/p1.patch')
-rw-r--r--app-backup/bup/files/p1.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/app-backup/bup/files/p1.patch b/app-backup/bup/files/p1.patch
deleted file mode 100644
index 3005498..0000000
--- a/app-backup/bup/files/p1.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-The .c and .o rules were not used and were misleadingly implying that we
-were already paying attention to LDFLAGS and CFLAGS. Instead apply the
-flags to csetup.py where they will actually do something.
-
-Signed-off-by: Brandon Low <lostlogic@lostlogicx.com>
----
- Makefile | 10 ++--------
- 1 files changed, 2 insertions(+), 8 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index d18e2ed..519ebe8 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,5 +1,5 @@
- OS:=$(shell uname | sed 's/[-_].*//')
--CFLAGS=-Wall -g -O2 -Werror $(PYINCLUDE) -g
-+CFLAGS:=-Wall -g -O2 -Werror $(PYINCLUDE) -g
- ifneq ($(OS),CYGWIN)
- CFLAGS += -fPIC
- endif
-@@ -71,7 +71,7 @@ install: all
- lib/bup/_helpers$(SOEXT): \
- lib/bup/bupsplit.c lib/bup/_helpers.c lib/bup/csetup.py
- @rm -f $@
-- cd lib/bup && $(PYTHON) csetup.py build
-+ cd lib/bup && LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)" $(PYTHON) csetup.py build
- cp lib/bup/build/*/_helpers$(SOEXT) lib/bup/
-
- .PHONY: lib/bup/_version.py
-@@ -96,9 +96,6 @@ test: all
-
- check: test
-
--%: %.o
-- $(CC) $(CFLAGS) (LDFLAGS) -o $@ $^ $(LIBS)
--
- bup: main.py
- rm -f $@
- ln -s $< $@
-@@ -123,9 +120,6 @@ cmd/bup-%: cmd/%-cmd.sh
- rm -f $@
- ln -s $*-cmd.sh $@
-
--%.o: %.c
-- gcc -c -o $@ $< $(CPPFLAGS) $(CFLAGS)
--
- # update the local 'man' and 'html' branches with pregenerated output files, for
- # people who don't have pandoc (and maybe to aid in google searches or something)
- export-docs: Documentation/all
---
-1.7.1
-