summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/fpipe/fpipe-9999.ebuild')
-rw-r--r--sci-astronomy/fpipe/fpipe-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/sci-astronomy/fpipe/fpipe-9999.ebuild b/sci-astronomy/fpipe/fpipe-9999.ebuild
index d5fbf0d..2c28fcd 100644
--- a/sci-astronomy/fpipe/fpipe-9999.ebuild
+++ b/sci-astronomy/fpipe/fpipe-9999.ebuild
@@ -12,8 +12,10 @@ EGIT_REPO_URI="git://git.tokkee.org/fpipe.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="debug"
+IUSE="debug +doc"
+# sci-astronomy/ftools is only needed because of the ape library, cfitsio and
+# xpa can be installed separately, an ebuild even exists for those.
DEPEND=">=x11-libs/gtk+-2.14
media-gfx/gtkimageview
dev-lang/perl
@@ -21,9 +23,8 @@ DEPEND=">=x11-libs/gtk+-2.14
dev-perl/XML-Simple
dev-perl/XML-SAX-Expat
virtual/perl-Time-HiRes
- perl-gcpan/IPC-XPA
virtual/libusb:1
- virtual/latex-base
+ doc? ( virtual/latex-base )
>=sci-astronomy/ftools-6.10"
pkg_setup() {
@@ -32,6 +33,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/pipeline_driver-Remove-references-to-IPC-XPA.patch
cd software
./bootstrap.sh || die "bootstrap failed"
}
@@ -45,8 +47,6 @@ src_configure() {
cd software
econf $(use_enable debug debug 1) \
- --disable-fpcmsimulator \
- --enable-fpimage \
--enable-fpixoacm2fits \
--enable-fpixosvm2fits \
--enable-fptemplate \
@@ -57,8 +57,10 @@ src_compile() {
cd software
emake || die "emake failed"
- cd "${S}"/documents
- emake || die "emake failed for documents"
+ if use doc; then
+ cd "${S}"/documents
+ emake || die "emake failed for documents"
+ fi
}
src_install() {
@@ -69,8 +71,10 @@ src_install() {
insinto /usr/share/"${PN}"/pipelinedef
doins *
- cd "${S}"/documents
- dodoc *.pdf *.odf
+ if use doc; then
+ cd "${S}"/documents
+ dodoc *.pdf *.odf
+ fi
}
pkg_postinst() {