summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ftools/ftools-6.6.1-r1.ebuild')
-rw-r--r--sci-astronomy/ftools/ftools-6.6.1-r1.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
index 33e1d7d..31ab5b3 100644
--- a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
+++ b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
@@ -15,57 +15,58 @@ KEYWORDS="~x86"
IUSE=""
RESTRICT="test"
-DEPEND="x11-base/xorg-server"
+DEPEND="x11-base/xorg-server
+ >=dev-lang/perl-5.6.0"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/heasoft-${PV}/"
+S="${WORKDIR}/heasoft-${PV}/BUILD_DIR"
PREFIX="/usr/heasoft-${PV}"
MSG="The HEASOFT General-Use FTools have been installed into
-$PREFIX.
+${PREFIX}.
-To use the HEASOFT, you need to set the HEADAS environment
-variable, and source the headas init script, like so
- export HEADAS=\"${PREFIX}/<arch-dependent-dir>\"
+To use the HEASOFT, you need to source the headas init script,
+like so
. \${HEADAS}/headas-init.sh
if you are using a bourne-shell. There is also an initscript
-for C-shells in the same directory as the one for bourne-shells."
+for C-shells in the same directory as the one for bourne-shells.
+The environment vairable \${HEADAS} has been defined for you."
+
+pkg_setup() {
+ [[ -d "${PREFIX}" ]] && die "Please unmerge previous installation."
+ ewarn "This ebuild works but doesn't do things as god intended..."
+}
src_prepare() {
for subdir in tcl tk; do
- cd "${S}"/tcltk/${subdir}/unix
+ cd "${S}"/../tcltk/${subdir}/unix
epatch "${FILESDIR}"/installManPage-S-namecollision.patch \
|| die "epatch failed"
done
}
src_configure() {
- [[ -d "${PREFIX}" ]] && die "Please unmerge previous installation."
- ewarn "This ebuild is no good."
- cd BUILD_DIR
econf --prefix="${PREFIX}" || die "econf failed"
}
-src_compile() {
- cd BUILD_DIR
- emake || die "emake failed"
-
- echo "${MSG}" > WTF
-}
-
src_install() {
# The heasoft install scripts don't allow for $DESTDIR. Thus we
# must let headas install itself. This is very, very bad.
addwrite "${PREFIX}"
einfo "Installing into ${PREFIX} directly..."
- cd BUILD_DIR
# Hell knows why we need -j1 here. But we sure need it.
emake -j1 install || die "emake install failed"
einfo "Moving ${PREFIX} to image directory..."
mkdir "${D}"/usr
mv "${PREFIX}" "${D}"/usr
+ echo "${MSG}" > WTF
dodoc WTF
+ echo "HEADAS=\"`grep "HD_TOP_EXEC_PFX.*= " Makefile | sed "s#^HD_TOP_EXEC_PFX.*= ##"`\"" > 99headas
+ doenvd 99headas
+}
+
+pkg_postinst() {
elog "${MSG}"
}