summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/fpipe/Manifest1
-rw-r--r--sci-astronomy/fpipe/fpipe-9999.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-astronomy/fpipe/Manifest b/sci-astronomy/fpipe/Manifest
new file mode 100644
index 0000000..4f10b01
--- /dev/null
+++ b/sci-astronomy/fpipe/Manifest
@@ -0,0 +1 @@
+EBUILD fpipe-9999.ebuild 1132 RMD160 8029c2b5687ccca9f48a14c783fcdfe888cddab1 SHA1 ca9382aa0d150814e07375d1513d6324f2ad3a1a SHA256 92fae1a46215f72945c37aedf750552ee5ac9835a89ecf21100187b2b1d58b77
diff --git a/sci-astronomy/fpipe/fpipe-9999.ebuild b/sci-astronomy/fpipe/fpipe-9999.ebuild
new file mode 100644
index 0000000..45f807d
--- /dev/null
+++ b/sci-astronomy/fpipe/fpipe-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit git flag-o-matic
+
+DESCRIPTION="A collection of FTools orchestrated by a pipeline driver"
+HOMEPAGE="http://pulsar.sternwarte.uni-erlangen.de/fpipe/"
+EGIT_REPO_URI="git://git.tokkee.org/fpipe.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.14
+ dev-lang/perl
+ dev-perl/gtk2-perl
+ dev-perl/XML-Simple
+ virtual/perl-Time-HiRes
+ sci-astronomy/ftools"
+
+pkg_setup() {
+ ewarn "Note: this software is not yet in a too mature status so expect some minor things to break"
+}
+
+src_prepare() {
+ cd software
+ ./bootstrap.sh
+}
+
+src_configure() {
+ filter-flags -O2
+ cd software
+ econf || die "econf failed"
+}
+
+src_compile() {
+ cd software
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd software
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ elog "Before using this package you need to initialise heasoft by"
+ elog "sourcing the headas-init script, like so"
+ elog " . ${HEADAS}/headas-init.sh"
+ elog "heasoft is sci-astronomy/ftools"
+}