summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ftools/Manifest7
-rw-r--r--sci-astronomy/ftools/files/hd_install-destdir.patch27
-rw-r--r--sci-astronomy/ftools/files/headas-init-destdir.patch38
-rw-r--r--sci-astronomy/ftools/files/lhea-fixperl-destdir.patch12
-rw-r--r--sci-astronomy/ftools/files/no-tk-docs.patch21
-rw-r--r--sci-astronomy/ftools/files/par2-destdir.patch14
-rw-r--r--sci-astronomy/ftools/ftools-6.6.1.ebuild69
7 files changed, 188 insertions, 0 deletions
diff --git a/sci-astronomy/ftools/Manifest b/sci-astronomy/ftools/Manifest
new file mode 100644
index 0000000..558ab33
--- /dev/null
+++ b/sci-astronomy/ftools/Manifest
@@ -0,0 +1,7 @@
+AUX hd_install-destdir.patch 874 RMD160 90d241360baa6fd8b7c059c9a2f97097abaa3ec1 SHA1 8ab3430b9dba2e1763a59f9df0994e8f67d1e6b4 SHA256 b338263cd300724646fb32d9a6233d9cf73a1baa3885a80a0d3ced44bdac7626
+AUX headas-init-destdir.patch 1659 RMD160 bbc161b0745c6843231f82b9d41b9e254f7d04b4 SHA1 18d74fa1c5fb0ef705a005185541bc5d034e8c0d SHA256 6f4b617921607e58c135b172b43e2b5a8b75cddb84f100733424395cbbac2672
+AUX lhea-fixperl-destdir.patch 418 RMD160 05deb5f4fca25c27d46af61d0d32f180fb423ab4 SHA1 4b8a94e11e9e798b6402f7d7b8788476e7d519d1 SHA256 cde19d8d6f6718f8eae74104b02e6e56ec15bb2c0c2dec3c1cbde5c3ae95fc94
+AUX no-tk-docs.patch 738 RMD160 d69e261c402d2e545f109495be999eaeb5d37620 SHA1 35ff2466c06df162e584b76ad3ef15d05b9e2f42 SHA256 0782fe89fc4d29eb4ba2c01f8d6420762060a156db7cb7cf7847f3a5a366f44c
+AUX par2-destdir.patch 580 RMD160 56efb9a0049486f7736fe6bcd08947de45599ffa SHA1 97e12b9bb9feccf1be3d3bc1b83a6e79d4078f37 SHA256 aba4b7ba28204b6863c5e8ade5528874ef0606e15d03b1ea167ab9732ac481d4
+DIST heasoft6.6.1src.tar.gz 41783649 RMD160 b03d23ad61023d9f9d8df247a448c8ad4d66f98d SHA1 58376bd6ce4dbc9cdb3a901c977602d120d0609e SHA256 f73e78e5a5b6af8b9db0aee66957bf450980455fc78a8d7aa056e6013b49285d
+EBUILD ftools-6.6.1.ebuild 1911 RMD160 ba849617b62ddbac13c1fab45157d1bbd05db7bf SHA1 078a2aa8bf1a5e5af3b2da31c835f2c630f677e9 SHA256 4e389dd716cb9e4e9243178c4c067b96f2839ced5ea5446b57c163f918069be7
diff --git a/sci-astronomy/ftools/files/hd_install-destdir.patch b/sci-astronomy/ftools/files/hd_install-destdir.patch
new file mode 100644
index 0000000..7508875
--- /dev/null
+++ b/sci-astronomy/ftools/files/hd_install-destdir.patch
@@ -0,0 +1,27 @@
+diff --git a/BUILD_DIR/hd_install.c b/BUILD_DIR/hd_install.c
+--- a/BUILD_DIR/hd_install.c
++++ b/BUILD_DIR/hd_install.c
+@@ -1459,6 +1459,7 @@ int HDinstall_file(int argc, char** argv, int status) {
+ char** nextArg;
+ char** tmpArg;
+ char* tmp_cp;
++ char* destdir;
+ InstallOptions opts = DEFAULT;
+
+ /* Process command line options which apply to this program. */
+@@ -1555,6 +1556,15 @@ int HDinstall_file(int argc, char** argv, int status) {
+ continue;
+ }
+
++ /* Prepend $DESTDIR if defined. */
++ if(NULL != (destdir = getenv("DESTDIR"))) {
++ char* newdest = NULL;
++ if(OK != (status = AppendPath(destdir, dest, &newdest, status)))
++ continue;
++ free(dest);
++ dest = newdest;
++ }
++
+ /* Give information. */
+ /* Perform installation. */
+ status = InstallFiles(src, dest, nextArg, &opts, status);
diff --git a/sci-astronomy/ftools/files/headas-init-destdir.patch b/sci-astronomy/ftools/files/headas-init-destdir.patch
new file mode 100644
index 0000000..213d67c
--- /dev/null
+++ b/sci-astronomy/ftools/files/headas-init-destdir.patch
@@ -0,0 +1,38 @@
+diff --git a/BUILD_DIR/Makefile.in b/BUILD_DIR/Makefile.in
+index f0a0fc0..bdfbb29 100644
+--- a/BUILD_DIR/Makefile.in
++++ b/BUILD_DIR/Makefile.in
+@@ -15,14 +15,18 @@ install: check-selection
+ @${MAKE} ${HD_SELECTED} HD_TARGET=$@
+ @./hd_install . ${HD_TOP_EXEC_PFX}/BUILD_DIR
+ @if [ -d ../glast ]; then \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.csh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.csh \
+ ${HD_TOP_EXEC_PFX}/fermi-init.csh ${HD_LN_S}; \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.sh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.sh \
+ ${HD_TOP_EXEC_PFX}/fermi-init.sh ${HD_LN_S}; \
+ else \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.csh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.csh \
+ ${HD_TOP_EXEC_PFX}/headas-init.csh ${HD_LN_S}; \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.sh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.sh \
+ ${HD_TOP_EXEC_PFX}/headas-init.sh ${HD_LN_S}; \
+ fi
+ @./hd_install -f hd_install${BSUF} ${HD_TOP_EXEC_PFX}/bin/hd_install${BSUF}
+@@ -34,8 +38,8 @@ install: check-selection
+ install-fguiparfiles:
+ @if [ -d ../ftools/guis/fgui ]; then \
+ echo "Creating .par2 files for fgui:"; \
+- HEADAS=${HD_TOP_EXEC_PFX}; export HEADAS; \
+- . ${HD_TOP_EXEC_PFX}/headas-init.sh; \
++ HEADAS=${DESTDIR}/${HD_TOP_EXEC_PFX}; export HEADAS; \
++ . ${DESTDIR}/${HD_TOP_EXEC_PFX}/headas-init.sh; \
+ echo "cd ../ftools/guis/fgui"; \
+ cd ../ftools/guis/fgui; \
+ echo "`which tclsh` convertpar.tcl ftools"; \
diff --git a/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch b/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
new file mode 100644
index 0000000..625f12a
--- /dev/null
+++ b/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
@@ -0,0 +1,12 @@
+diff --git a/heacore/BUILD_DIR/lhea-fixperl b/heacore/BUILD_DIR/lhea-fixperl
+index 927387b..e052b59 100755
+--- a/heacore/BUILD_DIR/lhea-fixperl
++++ b/heacore/BUILD_DIR/lhea-fixperl
+@@ -21,6 +21,7 @@ else
+ fi
+
+ for file in $filelist; do
++ file="$DESTDIR/$file"
+ if [ -f $file ]; then
+ if [ `grep -c '^#!.*perl' $file 2> /dev/null` -gt 0 ]; then
+ echo "Modifying $file to use Perl given by LHEAPERL at runtime."
diff --git a/sci-astronomy/ftools/files/no-tk-docs.patch b/sci-astronomy/ftools/files/no-tk-docs.patch
new file mode 100644
index 0000000..657c3c0
--- /dev/null
+++ b/sci-astronomy/ftools/files/no-tk-docs.patch
@@ -0,0 +1,21 @@
+diff --git a/tcltk/tk/unix/Makefile.in b/tcltk/tk/unix/Makefile.in
+--- a/tcltk/tk/unix/Makefile.in
++++ b/tcltk/tk/unix/Makefile.in
+@@ -600,7 +600,7 @@ gdb: wish
+ gdb ./wish --command=gdb.run
+ rm gdb.run
+
+-INSTALL_TARGETS = install-binaries install-libraries install-demos install-doc @EXTRA_INSTALL@
++INSTALL_TARGETS = install-binaries install-libraries install-demos @EXTRA_INSTALL@
+
+ install: $(INSTALL_TARGETS)
+
+@@ -1542,7 +1542,7 @@ package-config:
+ package-common:
+ cd $(DISTDIR)/unix/`arch`;\
+ $(MAKE); \
+- $(MAKE) install-libraries install-doc \
++ $(MAKE) install-libraries \
+ prefix=$(DISTDIR)/SUNWtcl/$(TCLVERSION) \
+ exec_prefix=$(DISTDIR)/SUNWtcl/$(TCLVERSION)/`arch`
+ mkdir -p $(DISTDIR)/SUNWtcl/$(TCLVERSION)/bin
diff --git a/sci-astronomy/ftools/files/par2-destdir.patch b/sci-astronomy/ftools/files/par2-destdir.patch
new file mode 100644
index 0000000..1d0fca5
--- /dev/null
+++ b/sci-astronomy/ftools/files/par2-destdir.patch
@@ -0,0 +1,14 @@
+diff --git a/BUILD_DIR/Makefile.in b/BUILD_DIR/Makefile.in
+--- a/BUILD_DIR/Makefile.in
++++ b/BUILD_DIR/Makefile.in
+@@ -34,8 +34,8 @@ install: check-selection
+ install-fguiparfiles:
+ @if [ -d ../ftools/guis/fgui ]; then \
+ echo "Creating .par2 files for fgui:"; \
+- HEADAS=${HD_TOP_EXEC_PFX}; export HEADAS; \
+- . ${HD_TOP_EXEC_PFX}/headas-init.sh; \
++ HEADAS=${DESTDIR}/${HD_TOP_EXEC_PFX}; export HEADAS; \
++ . ${DESTDIR}/${HD_TOP_EXEC_PFX}/headas-init.sh; \
+ echo "cd ../ftools/guis/fgui"; \
+ cd ../ftools/guis/fgui; \
+ echo "`which tclsh` convertpar.tcl ftools"; \
diff --git a/sci-astronomy/ftools/ftools-6.6.1.ebuild b/sci-astronomy/ftools/ftools-6.6.1.ebuild
new file mode 100644
index 0000000..c5607af
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.6.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+# A well-used example of an eclass function that needs eutils is epatch. If
+# your source needs patches applied, it's suggested to put your patch in the
+# 'files' directory and use:
+#
+# epatch "${FILESDIR}"/patch-name-here
+#
+# eclasses tend to list descriptions of how to use their functions properly.
+# take a look at /usr/portage/eclasses/ for more examples.
+
+DESCRIPTION="General-Use FTools for manipulating and inspecting FITS files"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html"
+SRC_URI="heasoft${PV}src.tar.gz"
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="x11-base/xorg-server"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/heasoft-${PV}/"
+
+
+src_prepare() {
+ # The same source file hd_install.c occurs multiple times, and needs to
+ # be patched to support $DESTDIR.
+ for subdir in . demo tcltk ftools heacore heatools; do
+ cd "${S}"/${subdir}/BUILD_DIR
+ epatch "${FILESDIR}"/hd_install-destdir.patch || die "epatch failed"
+ done
+ cd "${S}"
+ epatch "${FILESDIR}"/no-tk-docs.patch || die "epatch failed"
+ epatch "${FILESDIR}"/lhea-fixperl-destdir.patch || die "epatch failed"
+ epatch "${FILESDIR}"/headas-init-destdir.patch || die "epatch failed"
+}
+
+src_configure() {
+ cd BUILD_DIR
+ ./configure --prefix="/usr/heasoft-${PV}/" || die "configure failed"
+}
+
+src_compile() {
+ cd BUILD_DIR
+ make -j1 || die "make failed"
+}
+
+src_install() {
+ cd BUILD_DIR
+ make -j1 DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "make install failed"
+
+ #emake \
+ # prefix="${D}"/usr \
+ # mandir="${D}"/usr/share/man \
+ # infodir="${D}"/usr/share/info \
+ # libdir="${D}"/usr/$(get_libdir) \
+ # install || die "emake install failed"
+
+ # The portage shortcut to the above command is simply:
+ #
+ #einstall || die "einstall failed"
+}